Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase, mail # dev - DISCUSS: Have hbase require at least hadoop 1.0.0 in hbase 0.96.0?


Copy link to this message
-
Re: DISCUSS: Have hbase require at least hadoop 1.0.0 in hbase 0.96.0?
Mikhail Bautin 2012-03-08, 23:29
@Stack, Jonathan: thank you for your replies.

After some more internal discussion, we decided it might not be too hard
for us to implement stubs in our version of HDFS to accommodate the new API
requirements on the HBase side.

Putting some of the HDFS multi-version support plumbing in HFileSystem
sounds like a good idea going forward, though, even if we are removing
support for some of the versions.

Thanks,
--Mikhail

On Thu, Mar 8, 2012 at 9:08 AM, Stack <[EMAIL PROTECTED]> wrote:

> On Thu, Mar 8, 2012 at 12:31 AM, Jonathan Hsieh <[EMAIL PROTECTED]> wrote:
> > I feel some sympathy towards the existing user argument (we have plenty
> to
> > deal with) -- a compromise may be to have hbase core tested and focused
> on
> > a small number of hdfs versions (apache hadoop 1.0.0 and apache hadoop
> > 0.23.x are my first suggestions) and to have an interface that isolates
> all
> > the  the reflection checks that are currently sprinkled throughout the
> code
> > base into an interface which can be targeted to support other specific
> > HDFS/DFS flavors.  This would be saner and could explicitly be tested.
> >
>
> HBASE-5074 introduces HFilesystem, the hbase filesystem. In this new
> layer, HBASE-5074 does the new checksum facility.  It includes faking
> a call that is in a new hdfs that is not in older versions.  Perhaps
> its here that we should move all of our reflectioneering so its
> contained and grokable?
>
> St.Ack
>