Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hive >> mail # user >> error executing the tutorial -> https://cwiki.apache.org/confluence/display/Hive/HiveAws+HivingS3nRemotely


Copy link to this message
-
Re: error executing the tutorial -> https://cwiki.apache.org/confluence/display/Hive/HiveAws+HivingS3nRemotely
Ok, so back to basics.

correct me If I am wrong

You are trying to setup YARN using s3 as file system?
Then you want to use hive on top of it.

On Tue, Sep 10, 2013 at 4:48 PM, <[EMAIL PROTECTED]> wrote:

>  The issue is if I paste it in core-site.xml of Hadoop on the node in
> question, then will starting datanode would do only? Actually,. I am a bit
> confused what all daemons to start. I have a YARN architecture running 1
> separate – Resource  Manager, 1 NameNode &  4 datanodes.****
>
> ** **
>
> *From:* Nitin Pawar [mailto:[EMAIL PROTECTED]]
> *Sent:* Tuesday, September 10, 2013 4:43 PM
>
> *To:* [EMAIL PROTECTED]
> *Subject:* Re: error executing the tutorial ->
> https://cwiki.apache.org/confluence/display/Hive/HiveAws+HivingS3nRemotely
> ****
>
> ** **
>
> There is not more to start. If hive is not starting properly, it will not
> start at all so you are doing ok. ****
>
> ** **
>
> Problem is when you create table, hive tries to create a directory with
> that name if its not existing. Just try to put those two settings inside
> core-site.xml and see if the hdfs can use it to create directory ****
>
> ** **
>
> On Tue, Sep 10, 2013 at 4:06 PM, <[EMAIL PROTECTED]> wrote:**
> **
>
> The values are showing when I run “hive> set;” command. But it’s not
> getting identified. I guess I am not starting HIVE properly. Do you know
> what are the steps?****
>
>  ****
>
> *From:* Nitin Pawar [mailto:[EMAIL PROTECTED]]
> *Sent:* Tuesday, September 10, 2013 4:04 PM****
>
>
> *To:* [EMAIL PROTECTED]
> *Subject:* Re: error executing the tutorial ->
> https://cwiki.apache.org/confluence/display/Hive/HiveAws+HivingS3nRemotely
> ****
>
>  ****
>
> From the config file it looks ok. Not really sure why it is not picking up
> when you run it via hive cli. ****
>
>  ****
>
> Can you try putting these in core-site.xml of hdfs. ****
>
>  ****
>
>  ****
>
> <property>****
>
>     <name>fs.s3n.awsAccessKeyId</name>****
>
>     <value>ID</value>****
>
> </property>****
>
> <property>****
>
>     <name>fs.s3n.awsSecretAccessKey</name>****
>
>     <value>SECRET</value>****
>
> </property>****
>
>    ****
>
> On Tue, Sep 10, 2013 at 3:11 PM, <[EMAIL PROTECTED]> wrote:**
> **
>
> Hi Nitin,****
>
>  ****
>
> PFA hive-site.xml. I wanted to start Hortonworks HIVE. Can you please help.
> ****
>
>  ****
>
> Thanks,****
>
> Shouvanik****
>
>  ****
>
> *From:* Nitin Pawar [mailto:[EMAIL PROTECTED]]
> *Sent:* Tuesday, September 10, 2013 11:15 AM****
>
>
> *To:* [EMAIL PROTECTED]
> *Subject:* Re: error executing the tutorial ->
> https://cwiki.apache.org/confluence/display/Hive/HiveAws+HivingS3nRemotely
> ****
>
>  ****
>
> if you have set these values inside hive-site.xml and restarted hive
> service. It should work. ****
>
>  ****
>
> Share your hive-site.xml (please remove values for s3naccess key and
> secret ) ****
>
>  ****
>
> On Tue, Sep 10, 2013 at 3:17 AM, <[EMAIL PROTECTED]> wrote:**
> **
>
> Please help. I am badly stuck on this. Please help.****
>
>  ****
>
> *From:* Haldar, Shouvanik
> *Sent:* Tuesday, September 10, 2013 1:03 AM****
>
>
> *To:* '[EMAIL PROTECTED]'
> *Subject:* RE: error executing the tutorial ->
> https://cwiki.apache.org/confluence/display/Hive/HiveAws+HivingS3nRemotely
> ****
>
>  ****
>
> When I set values inside hive-site.xml & test whether values are set by
> typing hive> set; I see that the values are set.****
>
>  ****
>
> Yet, when I run “CREATE EXTERNAL TABLE…” command, I get the same error****
>
>  ****
>
> FAILED: Error in metadata:
> MetaException(message:java.lang.IllegalArgumentException: AWS Access Key ID
> and Secret Access Key must be specified as the username or password
> (respectively) of a s3n URL, or by setting the fs.s3n.awsAccessKeyId or
> fs.s3n.awsSecretAccessKey properties (respectively).)****
>
> FAILED: Execution Error, return code 1 from
> org.apache.hadoop.hive.ql.exec.DDLTask****
>
>  ****
>
> Please help.****
>
>  ****

Nitin Pawar