Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Zookeeper, mail # user - Re: ephemeral node not deleted after client session closed


+
kishore g 2011-11-11, 18:15
+
Jun Rao 2011-02-11, 18:01
+
Mahadev Konar 2011-02-11, 18:08
+
Jun Rao 2011-02-11, 18:43
+
Mahadev Konar 2011-02-11, 18:54
Copy link to this message
-
Re: ephemeral node not deleted after client long gone
Jun Rao 2011-02-11, 19:58
Hmm, I am pretty sure the client that created the ephemeral node is gone.
That client typically creates a bunch of ephemeral nodes. It seems that all
nodes except one is gone. The hanging ephemeral node can be read from any ZK
server and its info is listed below. Is there a way to get the information
of the client who created an ephemeral node (host, processid, etc)?

ctime = Fri Feb 11 04:39:25 PST 2011
mZxid = 0x1f03f5ea35
mtime = Fri Feb 11 04:39:25 PST 2011
pZxid = 0x1f03f5ea35
cversion = 0
dataVersion = 0
aclVersion = 0
ephemeralOwner = 0x22cab09a7380273
dataLength = 40
numChildren = 0

Thanks,

Jun

On Fri, Feb 11, 2011 at 10:54 AM, Mahadev Konar <[EMAIL PROTECTED]> wrote:

> Jun Rao,
>  No it cannot happen without a zookeeper restart.
>
> Are you sure you are shutting down the client?
>
> thanks
> mahadev
>
> On Fri, Feb 11, 2011 at 10:43 AM, Jun Rao <[EMAIL PROTECTED]> wrote:
> > Can the problems fixed in
> > https://issues.apache.org/jira/browse/ZOOKEEPER-962 and
> > https://issues.apache.org/<
> https://issues.apache.org/jira/browse/ZOOKEEPER-919>
> > jira/browse/ZOOKEEPER-919<
> https://issues.apache.org/jira/browse/ZOOKEEPER-919>
> > happen
> > even when there is no restart in the ZK server ensemble? For the problem
> > that I have seen, the ZK servers have always been up.
> >
> > Thanks,
> >
> > Jun
> >
> > On Fri, Feb 11, 2011 at 10:08 AM, Mahadev Konar <[EMAIL PROTECTED]>
> wrote:
> >
> >> Hi Jun,
> >>  Yes there was a bug reported:
> >>
> >> https://issues.apache.org/jira/browse/ZOOKEEPER-919
> >>
> >> Is this what you are seeing?
> >>
> >> thanks
> >> mahadev
> >>
> >> On Fri, Feb 11, 2011 at 10:01 AM, Jun Rao <[EMAIL PROTECTED]> wrote:
> >> > Hi,
> >> >
> >> > I found an issue in zookeeper 3.3.0 where an ephemeral node didn't get
> >> > deleted after the client was long gone. This seems to be a rare event
> and
> >> > happens 1 out of 600 tries. Has there been a similar problem
> >> reported/fixed?
> >> > Thanks,
> >> >
> >> > Jun
> >> >
> >>
> >
>
+
Fournier, Camille F. [Tec... 2011-02-11, 21:32
+
Jun Rao 2011-02-11, 22:49