Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Bigtop >> mail # user >> puppet error (probably my fault)


Copy link to this message
-
Re: puppet error (probably my fault)
I made some progress on this ....By adding

notice("in common-hdfs $hadoop_namenode_host <<<< ")
file {
   "/etc/hadoop/conf/core-site.xml"
   content => template('hadoop/core-site.xml'),
   require => [Package["hadoop"]],
}

I see that I get no value:

Notice: Scope(Class[Hadoop::Common-hdfs]): in common-hdfs  <<<<<
Could not find value for 'hadoop_namenode_host'

So that is what breaks the parser : I guess it wants that value
("hadoop_namenode_host") to be defined, in order to properly parse the
template.

But it IS defined in the datanode snippet, just not in the common-hdfs
puppet snippet.

So some how that variable "loses" its scoping or definition in init.pp but
im not sure how.   I am suspecting maybe the version of puppet is important
here, or else, maybe the ordering of components, or some other system
specific aspect of my config (I DONT think this could be a bug, given that
so many people are succesfully using bigtop puppet recipes).

On Thu, Jul 3, 2014 at 11:40 PM, jay vyas <[EMAIL PROTECTED]>
wrote:
jay vyas

 
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB