Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Sqoop, mail # dev - Review Request: SQOOP-796: Unable to use new Hadoop environment variables


Copy link to this message
-
Re: Review Request: SQOOP-796: Unable to use new Hadoop environment variables
Jarek Cecho 2012-12-25, 06:05

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/8685/#review14885
-----------------------------------------------------------
Hi Sean,
thank you very much for your patch. I just have one high level point:

1) Would you mind running "ant checkstyle" and fixing introduced style violations?
src/java/com/cloudera/sqoop/tool/BaseSqoopTool.java
<https://reviews.apache.org/r/8685/#comment31811>

    Please do not touch com.cloudera packages. They are deprecated and should not be used any more.
Thanks for your time!

Jarcec

- Jarek Cecho
On Dec. 19, 2012, 6:15 p.m., Sean Mackrory wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/8685/
> -----------------------------------------------------------
>
> (Updated Dec. 19, 2012, 6:15 p.m.)
>
>
> Review request for Sqoop.
>
>
> Description
> -------
>
> See JIRA for full description of the problem and solution.
>
>
> This addresses bug SQOOP-796.
>     https://issues.apache.org/jira/browse/SQOOP-796
>
>
> Diffs
> -----
>
>   bin/configure-sqoop ee1dd7b
>   bin/sqoop bc69083
>   conf/sqoop-env-template.sh 0294f17
>   src/docs/man/common-args.txt 129f5d1
>   src/docs/man/sqoop.txt 44b4f4e
>   src/docs/user/common-args.txt eff9939
>   src/docs/user/help.txt 11b4f0c
>   src/docs/user/tools.txt ce83a24
>   src/java/com/cloudera/sqoop/tool/BaseSqoopTool.java a5f72f7
>   src/java/org/apache/sqoop/SqoopOptions.java 2b5db29
>   src/java/org/apache/sqoop/orm/CompilationManager.java 26adcbf
>   src/java/org/apache/sqoop/tool/BaseSqoopTool.java 1ab3e5f
>   src/scripts/run-perftest.sh 2a4ba21
>   src/test/com/cloudera/sqoop/manager/PostgresqlImportTest.java 512b1d5
>
> Diff: https://reviews.apache.org/r/8685/diff/
>
>
> Testing
> -------
>
> Performed an import from MySQL on a pre-YARN MapReduce cluster (with HADOOP_HOME set) and a YARN cluster (with HADOOP_COMMON_HOME and HADOOP_MAPRED_HOME set). Although the YARN cluster failed, it appears to be after Sqoop has located all of it's dependencies and that the problem is with my YARN setup.
>
>
> Thanks,
>
> Sean Mackrory
>
>