Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase, mail # user - hbase config problem


Copy link to this message
-
Re: hbase config problem
Jean-Marc Spaggiari 2013-12-27, 19:54
You're welcome. Looking forward to helping you again ;)

JM
2013/12/27 Gerald Klein <[EMAIL PROTECTED]>

> OK Yea!! Looks like we got it with 96.1.1 can't say what the problem was
> but this one works. I am quite puzzled. But I wanted to thank you for your
> help and patience, quite more then I could expect. I truly appreciate your
> time and help with this.
>
> thanks again
>
> --jerry
>
>
> On Fri, Dec 27, 2013 at 1:21 PM, Jean-Marc Spaggiari <
> [EMAIL PROTECTED]> wrote:
>
> > Hadoop 2 is for Hadoop 2... Hadoop 1 is for.... guess.... Hadoop 1 ;)
> >
> > If you are running in distributed mode with Hadoop 2.x.x then use the tar
> > marked Hadoop 2.
> >
> > For standalone, I used Hadoop 1 version.
> >
> > Regarding your java_home it should point where you JDK is. In my own
> > environment it's /usr/local/jdk1.7.0_45 not the /bin nor the /bin/java.
> You
> > should not point to you ..../bin/java file. But into the JDK home
> > directory.
> >
> >
> > JM
> >
> >
> > 2013/12/27 Gerald Klein <[EMAIL PROTECTED]>
> >
> > > yes I will try with 96.1.1 let me ask you what is the difference
> between
> > > files marked hadoop 1 and hadoop 2?
> > >
> > >
> > > On Fri, Dec 27, 2013 at 1:01 PM, Jean-Marc Spaggiari <
> > > [EMAIL PROTECTED]> wrote:
> > >
> > > > That's strange. It's the same issue I get with trunk, but I don't
> face
> > > that
> > > > with 0.96.1.1. Are you testing with 0.96.0? Or 0.96.1.1? Can you try
> > with
> > > > 0.96.1.1?
> > > >
> > > >
> > > > 2013/12/27 Gerald Klein <[EMAIL PROTECTED]>
> > > >
> > > > > Ok sorry about the versions here is 96 I am not sure why the
> > > "localhost:"
> > > > > is there as you can see from the prompt, it is showing the logged
> in
> > > > domain
> > > > > as different.
> > > > >
> > > > > [[EMAIL PROTECTED] ~/Software/hbase-gz/hbase-0.96.0]#
> > (in
> > > > > ranger) bin/start-hbase.sh
> > > > > Error: Could not find or load main class
> > > > > org.apache.hadoop.hbase.util.HBaseConfTool
> > > > > Error: Could not find or load main class
> > > > > org.apache.hadoop.hbase.zookeeper.ZKServerTool
> > > > > starting master, logging to
> > > > >
> > > > >
> > > >
> > >
> >
> /root/Software/hbase-gz/hbase-0.96.0/bin/../logs/hbase-root-master-zenlinux.localdomain.com.out
> > > > > Error: Could not find or load main class
> > > > > org.apache.hadoop.hbase.master.HMaster
> > > > > Password:
> > > > > localhost: starting regionserver, logging to
> > > > >
> > > > >
> > > >
> > >
> >
> /root/Software/hbase-gz/hbase-0.96.0/bin/../logs/hbase-root-regionserver-zenlinux.localdomain.com.out
> > > > > localhost: Error: Could not find or load main class
> > > > > org.apache.hadoop.hbase.regionserver.HRegionServer
> > > > >
> > > > >
> > > > >
> > > > >
> > > > >
> > > > > On Fri, Dec 27, 2013 at 12:39 PM, Jean-Marc Spaggiari <
> > > > > [EMAIL PROTECTED]> wrote:
> > > > >
> > > > > > But it still log "localhost:" instead of the host name....
> > > > > >
> > > > > > Also, you are not trying each time with the same version.
> > > > > >
> > > > > > Initial log was:
> > > > > > /root/Software/hbase-gz/hbase-0.96.0
> > > > > > Now it's:
> > > > > > /root/Software/hbase-gz/hbase-0.95.2/
> > > > > >
> > > > > > Can you please make sure you test with 0.96.1.1? 0.95 was a dev
> > > > version.
> > > > > > 0.96 has been built from that.
> > > > > >
> > > > > > Can you paste on pastebin the output of "set"?
> > > > > >
> > > > > >
> > > > > > 2013/12/27 Gerald Klein <[EMAIL PROTECTED]>
> > > > > >
> > > > > > > Ok same problem still, it just seems like it just isn't
> locating
> > > the
> > > > > base
> > > > > > > classes.
> > > > > > >
> > > > > > > Error: Could not find or load main class
> > > > > > > org.apache.hadoop.hbase.util.HBaseConfTool
> > > > > > > Error: Could not find or load main class
> > > > > > > org.apache.hadoop.hbase.zookeeper.ZKServerTool
> > > > > > > starting master, logging to
> > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
> /root/Software/hbase-gz/hbase-0.95.2/bin/../logs/hbase-root-master-zenlinux.localdomain.com.out