Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> HRegionInfo was null or empty in -ROOT-


Copy link to this message
-
HRegionInfo was null or empty in -ROOT-
Hi all,

This morning I was restarting my HBase cluster, and I'm finding that the
region servers start up fine, but master always fails with the following
error shown in the web ui:

Problem accessing /master.jsp. Reason:

    Trying to contact region server null for region , row '', but
failed after 10 attempts.
Exceptions:
java.io.IOException: HRegionInfo was null or empty in -ROOT-,
row=keyvalues={.META.,,1/info:server/1301428760725/Put/vlen=33,
.META.,,1/info:serverstartcode/1301428760725/Put/vlen=8}
java.io.IOException: HRegionInfo was null or empty in -ROOT-,
row=keyvalues={.META.,,1/info:server/1301428760725/Put/vlen=33,
.META.,,1/info:serverstartcode/1301428760725/Put/vlen=8}
...

Caused by:
org.apache.hadoop.hbase.client.RetriesExhaustedException: Trying to
contact region server null for region , row '', but failed after 10
attempts.
Exceptions:
java.io.IOException: HRegionInfo was null or empty in -ROOT-,
row=keyvalues={.META.,,1/info:server/1301428760725/Put/vlen=33,
.META.,,1/info:serverstartcode/1301428760725/Put/vlen=8}
java.io.IOException: HRegionInfo was null or empty in -ROOT-,
row=keyvalues={.META.,,1/info:server/1301428760725/Put/vlen=33,
.META.,,1/info:serverstartcode/1301428760725/Put/vlen=8}
...

Here is what I get when I scan -ROOT-:
hbase(main):001:0> scan '-ROOT-'
ROW                                     COLUMN+CELL
 .META.,,1                              column=info:server,
timestamp=1301428760725, value=sspv2rndhadoop1.gce2000.com:60020
 .META.,,1                              column=info:serverstartcode,
timestamp=1301428760725, value=1301428748891

Any ideas what's going on / how I can fix this?
Cluster info: 4 nodes, hadoop-0.20-append, hbase-0.90.3, red hat 5.5,
64-bit, jdk1.6; 64 gb ram, 2.8ghz.
Thanks guys
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB