Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hadoop >> mail # general >> [VOTE] Release hadoop-1.x.x off branch-0.20-security


Copy link to this message
-
Re: [VOTE] Release hadoop-1.x.x off branch-0.20-security
I don't think we should vote it that way.
Because 0.23 and 0.22 become confusing in this case.
Unless you want to replace trunk with what is in 0.20.205.

The three branches 0.20.security, o.22, and 0.23 have very different
codes bases. So calling them 1, 2, and 3 respectively is natural.
But we should vote on a complex naming convention, not just the thing
which will be called Hadoop 1.
And try to make it less confusing for the users.

Thanks,
--Konstantin

On Tue, Nov 15, 2011 at 10:43 PM, Eric Baldeschwieler
<[EMAIL PROTECTED]> wrote:
> +1 (non-binding)
>
> Let's ship 1.0.0 off 0.20.205.*
>
> I think this will be great for the project.
>
> Arun, since you called the vote, can you clarify exactly what version of the 20.2xx.x line will be renamed or originally released as exactly what 1.0.x version?  It seems like following versions will take care of themselves, but let's vote on a specific action.
>
>
>
> On Nov 15, 2011, at 9:15 PM, Suresh Srinivas wrote:
>
>> +1
>>
>> My preference is to call it 1.0 and not as 1.6 to reflect 0.20.206.
>>
>>
>> On Nov 15, 2011, at 8:22 PM, Arun Murthy <[EMAIL PROTECTED]> wrote:
>>
>>> Please vote on naming 'future' releases off branch-0.20-security (with
>>> both security & append) as hadoop-1.x.x.
>>>
>>> We should also rename branch-0.20-security as branch-1.x.x.
>>>
>>> I propose we use the common 3-part major, minor (compatible, newer
>>> features) and sub-minor (bug fixes) scheme as suggested by Doug in the
>>> previous thread.
>>>
>>> The vote will run the normal 5 days.
>>>
>>> thanks,
>>> Arun
>
>