Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase >> mail # dev >> modularizing trunk


+
Jesse Yates 2012-05-09, 01:31
+
Ted Yu 2012-05-09, 01:51
+
Stack 2012-05-09, 17:43
+
Matt Corgan 2012-05-09, 18:18
+
Stack 2012-05-09, 19:01
+
Andrew Purtell 2012-05-09, 19:06
+
Jesse Yates 2012-05-09, 20:27
+
Matt Corgan 2012-05-09, 20:34
+
Elliott Clark 2012-05-09, 21:18
Copy link to this message
-
Re: modularizing trunk
Created
* HBASE-5976 to discuss the name of the initial package
* HBASE-5977 to discuss future naming/usage of packages

Go nuts.

-------------------
Jesse Yates
@jesse_yates
jyates.github.com
On Wed, May 9, 2012 at 2:18 PM, Elliott Clark <[EMAIL PROTECTED]>wrote:

> Starting with hbase-core seems to make sense. If we started with
> hbase-server there would be a while until all of the client and other
> packages were split up where org.apache.hadoop.hbase.client was in the
> hadoop-server jar.
>
> On Wed, May 9, 2012 at 1:34 PM, Matt Corgan <[EMAIL PROTECTED]> wrote:
>
> > Sorry about that - my intention was not to decide all future module
> names,
> > just to avoid having both core and common and to illustrate how we were
> > heading that direction.
> >
> >
> > On Wed, May 9, 2012 at 1:27 PM, Jesse Yates <[EMAIL PROTECTED]>
> > wrote:
> >
> > > I was worried this discussion around naming might happen. Should I
> open a
> > > sub-jira on 4336 for how to name the modules, what future modules
> should
> > > be, etc.?
> > >
> > > -Jesse
> > > -------------------
> > > Jesse Yates
> > > @jesse_yates
> > > jyates.github.com
> > >
> > >
> > > On Wed, May 9, 2012 at 12:06 PM, Andrew Purtell <[EMAIL PROTECTED]>
> > > wrote:
> > >
> > > > On Wed, May 9, 2012 at 12:01 PM, Stack <[EMAIL PROTECTED]> wrote:
> > > > > On Wed, May 9, 2012 at 11:18 AM, Matt Corgan <[EMAIL PROTECTED]>
> > > > wrote:
> > > > >> I'd suggest calling this first module hbase-server since the
> > majority
> > > of
> > > > >> the classes are related to the master and regionservers.  Then we
> > can
> > > > pull
> > > > >> out the fundamental classes (KeyValue, Bytes, etc) into a small
> > module
> > > > >> called hbase-core.  After that, we can create an hbase-client
> module
> > > > that
> > > > >> only depends on hbase-core (so few or no dependencies).  My main
> > point
> > > > >> being that we'll want to reserve the name hbase-core for the
> actual
> > > core
> > > > >> classes and not throw everything in there.
> > > > >>
> > > > >
> > > > > We don't want hbase-common and then hbase-core for sure.
> > > > >
> > > > > The first module rightly should be called hbase-bucket since its
> just
> > > > > a holding module while we do our sort-through.  Can we figure a
> name
> > > > > that better conveys the module as so?  hbase-hbase?  hbase-bucket?
> > > > > hbase-99%? hbase-pick-u-part?   hbase-residuum?
> > > >
> > > > hbase-server is as reasonable as any, right?
> > > >
> > > > Best regards,
> > > >
> > > >    - Andy
> > > >
> > > > Problems worthy of attack prove their worth by hitting back. - Piet
> > > > Hein (via Tom White)
> > > >
> > >
> >
>
+
Jesse Yates 2012-05-24, 06:27
+
Jesse Yates 2012-05-24, 19:29
+
Andrew Purtell 2012-05-24, 19:43
+
Stack 2012-05-25, 15:54
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB