Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Avro >> mail # user >> Problem fetching Netty jar with 1.4.1


+
Jeff Hammerbacher 2010-12-26, 20:13
+
Jeff Hammerbacher 2010-12-26, 20:20
+
Scott Carey 2010-12-26, 21:15
Copy link to this message
-
Re: Problem fetching Netty jar with 1.4.1
Ah, thanks, that's useful. Now to debug those missing field errors...

On Sun, Dec 26, 2010 at 1:15 PM, Scott Carey <[EMAIL PROTECTED]>wrote:

> Maven will not read the repository section from dependent projects.  HBase
> will need to set it.  This is because it is security-related -- a project
> must specify which repositories it trusts.  So HBase needs to decide if it
> trusts JBoss' repo, or provide any other repo that HBase trusts that
> contains the artifact.
>
>
>
> On Dec 26, 2010, at 12:13 PM, Jeff Hammerbacher wrote:
>
> Hey,
>
> I'm trying to upgrade HBase to Avro 1.4.1 and getting a problem when Maven
> tries to fetch Netty. It appears that the JBoss repository is not being
> searched; do I need to add the JBoss repository to the top-level HBase
> pom.xml, or should it find the JBoss repository in the Avro 1.4.1 pom.xml? I
> would have expected the latter, but when I explicitly copy the JBoss
> repository information from http://www.jboss.org/netty/downloads.html into
> the HBase pom.xml, the build works; when the JBoss repo is not added to the
> HBase pom, it breaks.
>
> I also noticed that the repository location specified in the Avro pom.xml
> is a bit different from the one specified at
> http://www.jboss.org/netty/downloads.html, but I would be surprised to
> learn that our pom.xml was busted for a release.
>
> So: any ideas on why HBase is having trouble finding the Netty jar?
>
> Thanks,
> Jeff
>
> Full error message:
>
> [INFO] Unable to find resource 'org.jboss.netty:netty:jar:3.2.1.Final' in
>> repository central (http://repo1.maven.org/maven2)
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Failed to resolve artifact.
>>
>> Missing:
>> ----------
>> 1) org.jboss.netty:netty:jar:3.2.1.Final
>>
>>   Try downloading the file manually from the project website.
>>
>>   Then, install it using the command:
>>       mvn install:install-file -DgroupId=org.jboss.netty
>> -DartifactId=netty -Dversion=3.2.1.Final -Dpackaging=jar
>> -Dfile=/path/to/file
>>
>>   Alternatively, if you host your own repository you can deploy the file
>> there:
>>       mvn deploy:deploy-file -DgroupId=org.jboss.netty -DartifactId=netty
>> -Dversion=3.2.1.Final -Dpackaging=jar -Dfile=/path/to/file -Durl=[url]
>> -DrepositoryId=[id]
>>
>>   Path to dependency:
>>       1) org.apache.hbase:hbase:jar:0.91.0-SNAPSHOT
>>       2) org.apache.avro:avro:jar:1.4.1
>>       3) org.jboss.netty:netty:jar:3.2.1.Final
>>
>> ----------
>> 1 required artifact is missing.
>>
>> for artifact:
>>   org.apache.hbase:hbase:jar:0.91.0-SNAPSHOT
>>
>> from the specified remote repositories:
>>   apache.snapshots (http://repository.apache.org/snapshots),
>>   temp-thrift (http://people.apache.org/~rawson/repo/<http://people.apache.org/%7Erawson/repo/>
>> ),
>>   central (http://repo1.maven.org/maven2),
>>   codehaus (http://repository.codehaus.org/),
>>   java.net (http://download.java.net/maven/2/)
>>
>
>
>