Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase, mail # dev - ANN: The first hbase 0.94.0 release candidate is available for download


Copy link to this message
-
Re: ANN: The first hbase 0.94.0 release candidate is available for download
Todd Lipcon 2012-03-29, 15:56
To be clear, a rolling restart from 90 to 94 isn't expected to work.
But a shutdown and restart ought to. (If not, like Jon said, we'll be
fixing it)

-Todd

On Wed, Mar 28, 2012 at 10:04 PM, Ramkrishna.S.Vasudevan
<[EMAIL PROTECTED]> wrote:
> Thanks Lars and Jon.
>
> I too expect the same to work.  I will try testing it that way.
>
> Regards
> Ram
>
>> -----Original Message-----
>> From: lars hofhansl [mailto:[EMAIL PROTECTED]]
>> Sent: Thursday, March 29, 2012 10:27 AM
>> To: [EMAIL PROTECTED]
>> Subject: Re: ANN: The first hbase 0.94.0 release candidate is available
>> for download
>>
>> I am not aware of anything that was removed from 0.94 that would
>> prevent that.
>> So to the extent that 0.90 can be upgraded in place to 0.92 it should
>> be possible to upgrade in 0.90 in place to 0.94.
>>
>> -- Lars
>>
>>
>>
>> ----- Original Message -----
>> From: Ramkrishna.S.Vasudevan <[EMAIL PROTECTED]>
>> To: [EMAIL PROTECTED]
>> Cc:
>> Sent: Wednesday, March 28, 2012 9:44 PM
>> Subject: RE: ANN: The first hbase 0.94.0 release candidate is available
>> for download
>>
>> Is it possible to upgrade from 0.90 to 0.94? Or should I upgrade to
>> 0.92 and
>> then only do a rolling restart to 0.94?
>>
>> Regards
>> Ram
>>
>> > -----Original Message-----
>> > From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]
>> > Sent: Thursday, March 29, 2012 9:50 AM
>> > To: [EMAIL PROTECTED]
>> > Cc: [EMAIL PROTECTED]
>> > Subject: Re: ANN: The first hbase 0.94.0 release candidate is
>> available
>> > for download
>> >
>> > I only used 0.94 for 20 minutes :-)
>> >
>> > It worked during that time. So yes to all questions.
>> >
>> >
>> >
>> > On Mar 28, 2012, at 9:14 PM, Stack <[EMAIL PROTECTED]> wrote:
>> >
>> > > Is it working for you Ted?  You going to +1 it?  You running on
>> > hadoop 0.22?
>> > > St.Ack
>> > >
>> > > On Wed, Mar 28, 2012 at 6:28 PM, Ted Yu <[EMAIL PROTECTED]>
>> wrote:
>> > >> The second scenario.
>> > >>
>> > >> Thanks
>> > >>
>> > >> On Wed, Mar 28, 2012 at 6:26 PM, lars hofhansl
>> <[EMAIL PROTECTED]>
>> > wrote:
>> > >>
>> > >>> HBASE-5258 is not in 0.94. Did you mean a different one?
>> > >>>
>> > >>> Or are you saying that you deployed HBASE-5258 locally to your
>> 0.92
>> > >>> version, and that that was the reason you could not test rolling
>> > upgrade to
>> > >>> 0.94?
>> > >>>
>> > >>> Thanks.
>> > >>>
>> > >>> -- Lars
>> > >>>
>> > >>>
>> > >>>
>> > >>> ________________________________
>> > >>>  From: Ted Yu <[EMAIL PROTECTED]>
>> > >>> To: [EMAIL PROTECTED]
>> > >>> Sent: Wednesday, March 28, 2012 5:11 PM
>> > >>> Subject: Re: ANN: The first hbase 0.94.0 release candidate is
>> > available
>> > >>> for download
>> > >>>
>> > >>> The change was for HBASE-5258
>> > >>>
>> > >>> Incompatibility was expected.
>> > >>>
>> > >>> Thanks
>> > >>>
>> > >>> On Wed, Mar 28, 2012 at 5:01 PM, Stack <[EMAIL PROTECTED]> wrote:
>> > >>>
>> > >>>> On Wed, Mar 28, 2012 at 3:54 PM, Ted Yu <[EMAIL PROTECTED]>
>> > wrote:
>> > >>>>> I planned to perform rolling restart from (our variant of) 0.92
>> > to
>> > >>> 0.94.0
>> > >>>>> but found out that some internal changes prevented region
>> server
>> > to
>> > >>> talk
>> > >>>> to
>> > >>>>> 0.94.0 master.
>> > >>>>
>> > >>>> What changes?  Do you have logs from that time?
>> > >>>> St.Ack
>> > >>>>
>> > >>>
>

--
Todd Lipcon
Software Engineer, Cloudera