Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Pig, mail # user - Grunt Shell hangs on Cygwin.


Copy link to this message
-
Re: Grunt Shell hangs on Cygwin.
Alan Gates 2013-08-08, 17:33
Yes, no cygwin tools are required.  You will need the hadoop version from branch-1-win as well as pig trunk to make this work.

Alan.

On Aug 5, 2013, at 10:03 PM, Darpan R wrote:

> Thanks Alan I am not sure if I quite understand this.
> Do you mean directly from Windows command prompt?
>
> Regards,
> Darpan
>
> On 6 August 2013 02:34, Alan Gates <[EMAIL PROTECTED]> wrote:
>
>> You might try running Pig trunk without cygwin.  Much work has been done
>> lately to make Pig work directly on windows.
>>
>> Alan.
>>
>> On Aug 4, 2013, at 9:49 PM, Darpan R wrote:
>>
>>> Thanks Sudhir,
>>> I tried running scripts , it takes a long time to start pig and stop (
>>> setup/cleanup) .
>>> Please keep us updated if any one is able to find the work around for the
>>> same.
>>>
>>> Thanks & Regards,
>>> Darpan
>>>
>>> On 3 August 2013 10:17, Sudhir N <[EMAIL PROTECTED]> wrote:
>>>
>>>> I have same problem, I could not find a solution, seems grunt doesn't
>> work
>>>> on Cygwin, I stopped trying.. I run scripts
>>>>
>>>>
>>>> Sudhir N
>>>>
>>>> -----Original Message-----
>>>> From: Darpan R [mailto:[EMAIL PROTECTED]]
>>>> Sent: Friday, August 02, 2013 6:59 PM
>>>> To: [EMAIL PROTECTED]
>>>> Subject: Grunt Shell hangs on Cygwin.
>>>>
>>>> Hi Guys,
>>>>
>>>> I am running Hadoop on local mode on my windows 7 machine (32 Bit).
>>>> I've installed HIVE/PIG/Hadoop/Java6 all on the C: drive.
>>>> I am using Cygwin version : 2.819.
>>>> PIG Version I tried with 0.11 and 0.10 (both I am facing issue) Hadoop
>>>> Version : 1.1.2 Hive Version : 0.10 Java version : 1.6 minor version 34
>>>>
>>>> I've mounted c: on the cygwin. I am able to run hadoop commands from the
>>>> cygwin terminal for example : fs -ls etc. I am also able to start grunt
>> and
>>>> hive shells.
>>>> But the real problem is :
>>>> Any command I enter on grunt shell ( example : fs -ls or records >>>> LOAD.....
>>>> ) I do not see any output, it kind of hangs.
>>>> Similarly with the hive prompt if I give the command as show tables ; I
>> do
>>>> not see any output just cursor keeps on blinking! Any keyboard inputs
>> and
>>>> gives NOTHING.
>>>> System appears to be doing NOTHING.
>>>> To me everything looks fine but definitely something is going wrong :-)
>>>>
>>>>
>>>> Here are my classpath and environment variables from .bashrc file:
>>>>
>>>> export JAVA_HOME=/c/Java/jdk1.6.0_34
>>>> export HADOOP_HOME=/c/Hadoop
>>>> export PIG_HOME=/c/PIG
>>>> export HIVE_HOME=/c/Hive
>>>> export HADOOP_BIN=$HADOOP_HOME/bin/hadoop
>>>> export PATH=$PATH:/c/Java/jdk1.6.0_34/bin
>>>> export PATH=$PATH:$HADOOP_HOME/bin
>>>> export PATH=$PATH:$HIVE_HOME/bin
>>>> export PATH=$PATH:$PIG_HOME/bin
>>>>
>>>> I am not sure if I am missing something. Any help will be highly
>>>> appreciated.
>>>>
>>>> Thanks & Regards,
>>>> -Darpan
>>>>
>>>>
>>
>>