Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo >> mail # dev >> Re: [jira] [Commented] (ACCUMULO-718) make the static methods in ColumnFQ instance methods


Copy link to this message
-
Re: [jira] [Commented] (ACCUMULO-718) make the static methods in ColumnFQ instance methods
I don't think we should keep them around after a phase of deprecation. They
already made the object, let the user call a method on it to attach it
instead of a static class.

But wouldn't it be better to have a method off scanner to fetch cfq instead
of the other way around?

Sent from my phone, so pardon the typos and brevity.
On Aug 7, 2012 3:06 PM, "Billie Rinaldi (JIRA)" <[EMAIL PROTECTED]> wrote:

>
>     [
> https://issues.apache.org/jira/browse/ACCUMULO-718?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13430535#comment-13430535]
>
> Billie Rinaldi commented on ACCUMULO-718:
> -----------------------------------------
>
> This is done.  Does anyone think we should keep the old static methods
> around?
>
> > make the static methods in ColumnFQ instance methods
> > ----------------------------------------------------
> >
> >                 Key: ACCUMULO-718
> >                 URL: https://issues.apache.org/jira/browse/ACCUMULO-718
> >             Project: Accumulo
> >          Issue Type: Improvement
> >          Components: client
> >    Affects Versions: 1.5.0-SNAPSHOT
> >            Reporter: Eric Newton
> >            Assignee: Billie Rinaldi
> >            Priority: Trivial
> >
> > Instead of
> > {noformat}
> > ColumnFQ.fetch(scanner, cfq);
> > {noformat}
> > we would write
> > {noformat}
> > cfq.fetch(scanner);
> > {noformat}
>
> --
> This message is automatically generated by JIRA.
> If you think it was sent incorrectly, please contact your JIRA
> administrators:
> https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
> For more information on JIRA, see: http://www.atlassian.com/software/jira
>
>
>