Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Drill >> mail # dev >> Review Request 22661: DRILL-996 - Allow other versions of Hadoop to be specified on command-line


Copy link to this message
-
Review Request 22661: DRILL-996 - Allow other versions of Hadoop to be specified on command-line

This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/22661/

Review request for drill and Aditya Kishore.
Bugs: DRILL-996
    https://issues.apache.org/jira/browse/DRILL-996
Repository: drill-git
Description

DRILL-996 - Allow other versions of Hadoop to be specified on command-line

Example usage:
- mvn install -DskipTests -Dapache.hadoop.version=1.1.0
- mvn install -DskipTests -Drat.numUnapprovedLicenses=1000 -Pmapr -Dmapr.hadoop.version=1.0.3-mapr-3.1.1 -Dmapr.hbase.version=0.94.17-mapr-1405-m7-3.1.1
- mvn install -DskipTests -Pcdh -Dcdh.hadoop.version=2.3.0-cdh5.0.2
- mvn install -DskipTests -Phdp -Dhdp.hadoop.version=2.4.0.2.1.2.0-402

However, this violates the Maven principle of the POM describing the JAR's dependencies. Scripting to change the POM itself was considered inappropriate at this time.
Diffs

  pom.xml e1617df

Diff: https://reviews.apache.org/r/22661/diff/
Testing
Thanks,

Patrick Wong