Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Zookeeper, mail # user - Problem reading/writing data on new 3.4.4 cluster


Copy link to this message
-
Re: Problem reading/writing data on new 3.4.4 cluster
Patrick Hunt 2012-10-31, 06:20
That's really odd. The client timeout means that the clients don't
hear from the server within the specified time (2/3 the session
timeout, or 20 seconds). However the session is established before
this, so communication (localhost) seems fine in general. Your "/" is
empty? i.e. you created a new zk, or did you create some znodes in
this directory prior to running the "ls /"?

I see that you're connecting the client to localhost:2181, what does
the configuration of the three servers look like? (can you attach
them?)

We have seen some issues with 3.4.4 on jdk7, but I don't think that's
the same thing here. You might try using 3.4.3 or jdk6 instead to see
if that helps.

Patrick

On Tue, Oct 30, 2012 at 3:17 PM, Brett Hoerner <[EMAIL PROTECTED]> wrote:
> Hi,
>
> I've created a 3 node Zookeeper 3.4.4 cluster (running under
> Exhibitor, but that shouldn't matter). They come up, elect a leader
> and seem generally happy. Exhibitor shows them as green and pings them
> regularly with "ruok".
>
> When I try to read or write anything to them (from Exhibitor or from
> zkCli.sh) I get a timeout error, though. I've attached logs of me
> connecting to the localhost ZK and attempting a / to no avail.
>
> https://gist.github.com/12354d7488e2fe4a26e2
>
> How do I go about debugging this? I don't see any clues as to what
> could be wrong. What other information can I provide?
>
> Thanks,
> Brett