Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Avro >> mail # user >> Java MapReduce Avro Jackson Error


Copy link to this message
-
Re: Java MapReduce Avro Jackson Error
On Mon, Mar 19, 2012 at 6:23 PM, Deepak Nettem <[EMAIL PROTECTED]> wrote:
> Hi Tatu / Scott,
>
> Thanks for your replies. I replaced the earlier dependencies with these:
...
> I still get the same error. Is there anything specific I need to do other
> than changing dependencies in pom.xml to make this error go away?

Sounds like some other library has been compiled against old Jackson
version then.
Perhaps one of hadoop core jars?

Whatever library it is needs to be compiled against Jackson 1.1 or newer.

-+ Tatu +-
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB