Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
MapReduce >> mail # user >> Please upgrade the Commons Configuration jar


Copy link to this message
-
Please upgrade the Commons Configuration jar
The 0.23.7 distribution of Hadoop still contains the 1.6 version of Commons
Configuration.

It is a version released on 2008-12-25, almost *five years* ago.

Could you at least upgrade it to 1.8 (three years old)? 1.6 is giving us
constant headaches as it misses a method

java.lang.NoSuchMethodError:
org.apache.commons.configuration.PropertiesConfigurationLayout.setGlobalSeparator(Ljava/lang/String;)V

that is used by the DSI utilities, WebGraph, MG4J to generate
bash-sourceable property files.

I have replaced 1.6 with 1.8 directly into the Hadoop distribution and
works like a charm.

Thanks!

seba
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB