Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> Hbase Read/Write throughput measure


Copy link to this message
-
Re: Hbase Read/Write throughput measure
Hi anil,

How to recompile it ?

Sent from my iPhone

On 2013-02-03, at 8:00 PM, "anil gupta" <[EMAIL PROTECTED]> wrote:

> Hi Dalia,
>
> Recently, i ran into same problem with YCSB. You will need to recompile
> YCSB with HBase0.92. Download the maven project from yscb site and
> recompile it with HBase0.92.
>
> HTH,
> Anil Gupta
>
> On Sun, Feb 3, 2013 at 9:49 AM, Dalia Sobhy <[EMAIL PROTECTED]>wrote:
>
>>
>> Hello Mohamed,
>>
>> Yes Hbase is running good and already I have a table and and some records
>> there.
>>
>> I have done what you told me I copied all jar files from lib directory to
>> YSCB/db/hbase/lib/ directory. After restart and writing this command
>> "./bin/ycsb run hbase -p columnfamily=family -P workloads/workloada", I
>> receive the same error.
>>
>> But I didn't compile, because already I don't have a .java file
>>
>> ycsb-0.1.4 directory doesn't contain hbase client java file, it contains
>> only this "hbase-binding-0.1.4.jar"
>>
>> So what to do ?
>>
>>
>>> From: [EMAIL PROTECTED]
>>> Date: Sun, 3 Feb 2013 22:54:13 +0530
>>> Subject: Re: Hbase Read/Write throughput measure
>>> To: [EMAIL PROTECTED]
>>>
>>> Hello Dalia,
>>>
>>>        Is your Hbase running OK? Copy the hbase jar from your HBASE_HOME
>>> and all the jars from your HBASE_HOME/lib/ directory to your
>>> YSCB/db/hbase/lib/ directory, compile it again and restart everything.
>>>
>>> Warm Regards,
>>> Tariq
>>> https://mtariq.jux.com/
>>> cloudfront.blogspot.com
>>>
>>>
>>> On Sun, Feb 3, 2013 at 10:18 PM, Dalia Sobhy <[EMAIL PROTECTED]
>>> wrote:
>>>
>>>>
>>>> Hello Mohamed,
>>>>
>>>> I believe thats not the case.
>>>>
>>>> check this blog
>> http://stackoverflow.com/questions/11649824/hbase-error-not-a-hostport-pair
>>>>
>>>> It denotes that this error is due to incompatible Hbase client and
>> server
>>>> versions, although I am using Hbase server :0.92 and the server is the
>>>> latest one uploaded by ycsb. So I don't know why this is happening.
>>>>
>>>> So do you have any idea?
>>>>
>>>> This is the cmd I am executing:
>>>>
>>>> root@master1:~/ycsb-0.1.4# ./bin/ycsb run hbase -p
>> columnfamily="family"
>>>> -P workloads/workloada
>>>>
>>>> java -cp
>> /home/dalia/ycsb-0.1.4/gemfire-binding/conf:/home/dalia/ycsb-0.1.4/hbase-binding/lib/hbase-binding-0.1.4.jar:/home/dalia/ycsb-0.1.4/hbase-binding/conf:/home/dalia/ycsb-0.1.4/jdbc-binding/conf:/home/dalia/ycsb-0.1.4/voldemort-binding/conf:/home/dalia/ycsb-0.1.4/infinispan-binding/conf:/home/dalia/ycsb-0.1.4/nosqldb-binding/conf:/home/dalia/ycsb-0.1.4/core/lib/core-0.1.4.jar
>>>> com.yahoo.ycsb.Client -db com.yahoo.ycsb.db.HBaseClient -p
>>>> columnfamily=family -P workloads/workloada -t
>>>> YCSB Client 0.1
>>>> Command line: -db com.yahoo.ycsb.db.HBaseClient -p columnfamily=family
>> -P
>>>> workloads/workloada -t
>>>> Loading workload...
>>>> Starting test.
>>>> 13/02/03 18:42:24 INFO zookeeper.ZooKeeper: Client
>>>> environment:zookeeper.version=3.3.2-1031432, built on 11/05/2010 05:32
>> GMT
>>>> 13/02/03 18:42:24 INFO zookeeper.ZooKeeper: Client environment:
>> host.name>>>> master1.medcloud.com
>>>> 13/02/03 18:42:24 INFO zookeeper.ZooKeeper: Client
>>>> environment:java.version=1.6.0_31
>>>> 13/02/03 18:42:24 INFO zookeeper.ZooKeeper: Client
>>>> environment:java.vendor=Sun Microsystems Inc.
>>>> 13/02/03 18:42:24 INFO zookeeper.ZooKeeper: Client
>>>> environment:java.home=/usr/lib/jvm/j2sdk1.6-oracle/jre
>>>> 13/02/03 18:42:24 INFO zookeeper.ZooKeeper: Client
>> environment:java.class.path=/home/dalia/ycsb-0.1.4/gemfire-binding/conf:/home/dalia/ycsb-0.1.4/hbase-binding/lib/hbase-binding-0.1.4.jar:/home/dalia/ycsb-0.1.4/hbase-binding/conf:/home/dalia/ycsb-0.1.4/jdbc-binding/conf:/home/dalia/ycsb-0.1.4/voldemort-binding/conf:/home/dalia/ycsb-0.1.4/infinispan-binding/conf:/home/dalia/ycsb-0.1.4/nosqldb-binding/conf:/home/dalia/ycsb-0.1.4/core/lib/core-0.1.4.jar
>>>> 13/02/03 18:42:24 INFO zookeeper.ZooKeeper: Client
>> environment:java.library.path=/usr/lib/jvm/j2sdk1.6-oracle/jre/lib/amd64/server:/usr/lib/jvm/j2sdk1.6-oracle/jre/lib/amd64:/usr/lib/jvm/j2sdk1.6-oracle/jre/../lib/amd64:/usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib