Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hive, mail # dev - Can hive-0.8.0 could work with HBase-0.92.0 and Zookeeper-3.4.2


Copy link to this message
-
Can hive-0.8.0 could work with HBase-0.92.0 and Zookeeper-3.4.2
Bing Li 2012-04-13, 10:20
Hi, guys
Currently, I run hive-0.8.0 UT with
- hadoop-1.0.0 (apply patchs for HIVE-2631 and HIVE-2629
- hbase-0.92.0
- zookeeper-3.4.2

But got the following error messages:

     [echo] Project: hbase-handler
    [junit] Running org.apache.hadoop.hive.cli.TestHBaseCliDriver
    [junit] org.apache.hadoop.hbase.client.NoServerForRegionException:
Unable to find region for  after 10 tries.
    [junit] at
org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation.locateRegionInMeta(HConnectionManager.java:908)
    [junit] at
org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation.locateRegion(HConnectionManager.java:814)
    [junit] at
org.apache.hadoop.hbase.client.HConnectionManager$HConnectionImplementation.locateRegion(HConnectionManager.java:782)
    [junit] at
org.apache.hadoop.hbase.client.HTable.finishSetup(HTable.java:249)
    [junit] at org.apache.hadoop.hbase.client.HTable.<init>(HTable.java:213)
    [junit] at
org.apache.hadoop.hive.hbase.HBaseTestSetup.setUpFixtures(HBaseTestSetup.java:95)
    [junit] at
org.apache.hadoop.hive.hbase.HBaseTestSetup.preTest(HBaseTestSetup.java:61)
    [junit] at
org.apache.hadoop.hive.hbase.HBaseQTestUtil.<init>(HBaseQTestUtil.java:31)
    [junit] at
org.apache.hadoop.hive.cli.TestHBaseCliDriver.setUp(TestHBaseCliDriver.java:43)
    [junit] at junit.framework.TestCase.runBare(TestCase.java:132)
    [junit] at junit.framework.TestResult$1.protect(TestResult.java:110)
    [junit] at junit.framework.TestResult.runProtected(TestResult.java:128)
    [junit] at junit.framework.TestResult.run(TestResult.java:113)
    [junit] at junit.framework.TestCase.run(TestCase.java:124)
    [junit] at junit.framework.TestSuite.runTest(TestSuite.java:243)
    [junit] at junit.framework.TestSuite.run(TestSuite.java:238)
    [junit] at
junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
    [junit] at junit.extensions.TestSetup$1.protect(TestSetup.java:23)
    [junit] at junit.framework.TestResult.runProtected(TestResult.java:128)
    [junit] at junit.extensions.TestSetup.run(TestSetup.java:27)
    [junit] at
org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.run(JUnitTestRunner.java:518)
    [junit] at
org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.launch(JUnitTestRunner.java:1052)
    [junit] at
org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.main(JUnitTestRunner.java:906)
    [junit] Exception: Unable to find region for  after 10 tries.
Referred to HIVE-2748, I
- add jaskson-mapper-asl and jackson-core-asl to resolve "No class found"
error
- modify HBaseTestSetup.java
 //    conf.set("hbase.master",
hbaseCluster.getHMasterAddress().toString());
    conf.set("hbase.master",
hbaseCluster.getMaster().getServerName().getHostAndPort());