Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo, mail # dev - RE: [External]  Re: Need help getting Accumulo running.


Copy link to this message
-
Re: [External] Re: Need help getting Accumulo running.
Jim Klucar 2012-07-06, 01:35
That's a weird one then. You can shut down accumulo and re-run the
init to see if you just mis-typed the password or something. By any
chance did you use non-ascii characters in your password?

On Thu, Jul 5, 2012 at 9:31 PM, Park, Jee [USA] <[EMAIL PROTECTED]> wrote:
> Yes, I can
>
> -----Original Message-----
> From: Jim Klucar [mailto:[EMAIL PROTECTED]]
> Sent: Thursday, July 05, 2012 9:31 PM
> To: [EMAIL PROTECTED]
> Subject: Re: [External] Re: Need help getting Accumulo running.
>
> Can you see the monitor page at http://localhost:50095 ?
>
>
> On Thu, Jul 5, 2012 at 9:26 PM, Park, Jee [USA] <[EMAIL PROTECTED]> wrote:
>> That's exactly what I typed in for the password, however it is still
>> giving me that error. Also, if it makes any difference, I have not
>> changed anything in the accumulo-site.xml file.
>>
>> -----Original Message-----
>> From: Jim Klucar [mailto:[EMAIL PROTECTED]]
>> Sent: Thursday, July 05, 2012 9:25 PM
>> To: [EMAIL PROTECTED]
>> Subject: Re: [External] Re: Need help getting Accumulo running.
>>
>> It is asking for the password you setup for the accumulo root user,
>> not the machine root user. It's whatever you typed in when you ran the
>> $ACCUMULO_HOME/bin/accumulo init   command.
>>
>> On Thu, Jul 5, 2012 at 9:21 PM, Park, Jee [USA] <[EMAIL PROTECTED]> wrote:
>>> Hello,
>>> I currently have hadoop, zookeeper and accumulo running, however I
>>> keep getting the following error when trying to start the accumulo shell:
>>>
>>> ~$: accumulo/bin/accumulo shell -u root Enter current password for
>>> 'root'@'accumulo': ********
>>> 05 18:18:26,233 [shell.Shell] ERROR:
>>> org.apache.accumulo.core.client.AccumuloSecurityException: Error
>>> BAD_CREDENTIALS - Username or Password is Invalid
>>>
>>> Thanks in advance.
>>> -----Original Message-----
>>> From: David Medinets [mailto:[EMAIL PROTECTED]]
>>> Sent: Friday, June 29, 2012 7:37 PM
>>> To: [EMAIL PROTECTED]
>>> Subject: [External] Re: Need help getting Accumulo running.
>>>
>>> oh... I think you missed a few steps from the gist:
>>>
>>> $ cd ~
>>> $ export TAR_DIR=~/workspace/accumulo/src/assemble/target
>>> $ tar xvzf $TAR_DIR/accumulo-1.5.0-incubating-SNAPSHOT-dist.tar.gz
>>>
>>> # Add the following to your .bashrc file.
>>> $ export ACCUMULO_HOME=~/accumulo-1.5.0-incubating-SNAPSHOT
>>>
>>> $ cd $ACCUMULO_HOME/conf
>>>
>>> These are the steps where you unpack the newly-created gz file into
>>> your home directory. It seems like you are running Accumulo from the
>>> source code directory. Also notice that I wrote those steps for
>>> v1.5.0 which might be different from v1.4.0
>>>
>>> On Fri, Jun 29, 2012 at 2:58 PM, Miguel Pereira
>>> <[EMAIL PROTECTED]>
>>> wrote:
>>>> Hi Jee,
>>>>
>>>> I used that same guide to install Accumulo, but I used this guide to
>>>> install hadoop.
>>>>
>>>> http://www.michael-noll.com/tutorials/running-hadoop-on-ubuntu-linux
>>>> -
>>>> s
>>>> ingle-node-cluster/
>>>>
>>>> furthermore here are the steps I took to install accumulo were I
>>>> used version 1.4.0 and standalone conf.
>>>> please note you also need to install java jdk, and set your
>>>> JAVA_HOME i used jdk 1.7
>>>>
>>>> Setting up Accumulo
>>>>
>>>>
>>>>   - git clone     git://github.com/apache/accumulo.git
>>>>   - cd accumulo
>>>>   - git checkout     tags/1.4.0 -b 1.4.0
>>>>   - mvn package && mvn assembly:single -N.             // this can
>>>> take a
>>>>   while
>>>>   - cp conf/examples/512MB/standalone/* conf
>>>>   - vi accumulo-env.sh
>>>>
>>>>
>>>> test -z "$JAVA_HOME" && export
>>>> JAVA_HOME=/home/hduser/pkg/jdk1.7.0_04
>>>> test -z "$HADOOP_HOME" && export
>>>> HADOOP_HOME=/home/hduser/developer/workspace/hadoop
>>>> test -z "$ZOOKEEPER_HOME" && export
>>>> ZOOKEEPER_HOME=/home/hduser/developer/workspace/zookeeper-3.3.5
>>>>
>>>>   - vi     accumulo-site.xml
>>>>
>>>>
>>>>    modify user, password, secret, memory
>>>>
>>>>
>>>>   - bin/accumulo     init
>>>>   - bin/start-all.sh
>>>>   - bin/accumulo     shell -u root