Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase >> mail # dev >> Eclipse build broken?


+
lars hofhansl 2012-11-30, 00:21
+
Nick Dimiduk 2012-11-30, 01:29
+
Enis Söztutar 2012-11-30, 01:51
+
Enis Söztutar 2012-11-30, 02:06
+
lars hofhansl 2012-11-30, 02:48
Copy link to this message
-
Re: Eclipse build broken?
I saw this last week too, same issue in my eclipse environment after
regenerating via mvn eclipse:eclipse to account for the new modules.

On Friday, November 30, 2012, lars hofhansl wrote:

> The reference in my Eclipse looks like this (in the hbase-it module):
>
> /home/lars/dev/hbase-trunk/hbase-server/src/test/resources
>
>
> Which is strange on two accounts:
> 1. Why is this an absolute path?
> 2. Why does it point to a resource in the hbase-server module?
>
> I'll try eclipse:clean and see what happens.
>
> -- Lars
>
>
> ----- Original Message -----
> From: Enis Söztutar <[EMAIL PROTECTED] <javascript:;>>
> To: "[EMAIL PROTECTED] <javascript:;>" <[EMAIL PROTECTED]<javascript:;>
> >
> Cc: lars hofhansl <[EMAIL PROTECTED] <javascript:;>>
> Sent: Thursday, November 29, 2012 6:06 PM
> Subject: Re: Eclipse build broken?
>
> I've done:
>
> git pull origin trunk
> mvn clean install -DskipTests
> Eclipse -> import maven project
>
> Did not get any problems.
>
> Recent issues committed into hbase-it are:
> HBASE-7225 and HBASE-7200
>
> Lars, what is the offending reference?
>
>
> On Thu, Nov 29, 2012 at 5:51 PM, Enis Söztutar <[EMAIL PROTECTED]<javascript:;>>
> wrote:
>
> > Let me get a fresh checkout and see
> >
> >
> > On Thu, Nov 29, 2012 at 5:29 PM, Nick Dimiduk <[EMAIL PROTECTED]<javascript:;>>
> wrote:
> >
> >> I pulled trunk yesterday and set up eclipse - with Enis's help,
> actually.
> >> I
> >> thought I was experiencing user error. A `mvn eclipse:clean` followed
> by a
> >> workspace refresh resolved the issues.
> >>
> >> -n
> >> On Nov 29, 2012 4:22 PM, "lars hofhansl" <[EMAIL PROTECTED]<javascript:;>>
> wrote:
> >>
> >> > The hbase-it project appears to have a bogus reference to resource in
> >> the
> >> > hbase-server project.
> >> > Removing that reference fixes the build problem. Is that correct?
> >> >
> >> > Enis, could you have a look at it?
> >> >
> >> > -- Lars
> >> >
> >>
> >
> >
>
>

--
Best regards,

   - Andy

Problems worthy of attack prove their worth by hitting back. - Piet Hein
(via Tom White)
+
Andrew Purtell 2012-11-30, 14:12
+
Enis Söztutar 2012-11-30, 19:41
+
Nick Dimiduk 2012-12-02, 23:55
+
Sergey Shelukhin 2012-11-30, 02:59
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB