Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Chukwa, mail # user - Re: Chukwa setup issues


Copy link to this message
-
Re: Chukwa setup issues
Bill Graham 2011-04-02, 05:50
I'm forwarding this email to chukwa-user, where you'll have a better
chance of getting an answer than on the hadoop common lists. (I'm not
that familiar with hicc.)

On Fri, Apr 1, 2011 at 5:19 PM, bikash sharma <[EMAIL PROTECTED]> wrote:
> I was trying to install HICC in Chukwa, but hicc.sh does not exist in the
> repository.
> Any idea?
> -bikash
>
> On Fri, Apr 1, 2011 at 5:57 PM, bikash sharma <[EMAIL PROTECTED]>
> wrote:
>>
>> Thanks Bill.
>> I am able to connect via web now, actually had put wrong http port in
>> config file.
>> One following question - if i run a mapreduce program say terasort, how
>> can we link chukwa to collect job metrics via web.
>>
>> On Fri, Apr 1, 2011 at 5:37 PM, Bill Graham <[EMAIL PROTECTED]> wrote:
>>>
>>> Unfortunately conf/collectors is used in two different ways in Chukwa,
>>> each with a different syntax. This should really be fixed.
>>>
>>> 1. The script that starts the collectors looks at it for a list of
>>> hostnames (no ports) to start collectors on. To start it just on one
>>> host, set it to localhost.
>>> 2. The agent looks at that file for the list of collectors to attempt
>>> to communicate with. In that case the format is a list of HTTP urls
>>> with ports of the collectors.
>>>
>>> Can you telnet to port 9999? It looks like it's listening, but
>>> nothing's being sent. Is there anything in logs/collector.log?
>>>
>>> On Fri, Apr 1, 2011 at 1:09 PM, bikash sharma <[EMAIL PROTECTED]>
>>> wrote:
>>> > Hi,
>>> > I am trying to setup Chukwa for a 16-node Hadoop cluster.
>>> > I followed the admin guide -
>>> > http://incubator.apache.org/chukwa/docs/r0.4.0/admin.html#Agents
>>> > However, I ran two the following issues:
>>> > 1. What should be the collector port that needs to be specified in
>>> > conf/collectors file
>>> > 2. Am unable to see the collector running via web browser
>>> >
>>> > Am I missing something?
>>> >
>>> > Thanks in advance.
>>> >
>>> > -bikash
>>> >
>>> > p.s. - after i run collector, nothing happens
>>> > % bin/chukwa collector
>>> > 2011-04-01 16:07:16.410::INFO:  Logging to STDERR via
>>> > org.mortbay.log.StdErrLog
>>> > 2011-04-01 16:07:16.523::INFO:  jetty-6.1.11
>>> > 2011-04-01 16:07:17.707::INFO:  Started
>>> > SelectChannelConnector@0.0.0.0:9999
>>> > started Chukwa http collector on port 9999
>>> >
>>
>
>