Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Avro >> mail # user >> Java MapReduce Avro Jackson Error


Copy link to this message
-
Re: Java MapReduce Avro Jackson Error
On Mon, Mar 19, 2012 at 4:20 PM, Deepak Nettem <[EMAIL PROTECTED]> wrote:
> I found that the Hadoop lib directory contains jackson-core-asl-1.0.1.jar
> and jackson-mapper-asl-1.0.1.jar.
>
> I removed these, but got this error:
> hadoop Exception in thread "main" java.lang.NoClassDefFoundError:
> org/codehaus/jackson/map/JsonMappingException
>
> I am using Maven as a build tool, and my pom.xml has this dependency:
>
>     <dependency>
>     <groupId>org.codehaus.jackson</groupId>
>       <artifactId>jackson-mapper-asl</artifactId>
>       <version>1.5.2</version>
>       <scope>compile</scope>
>     </dependency>
>
> Any help would on this issue would be greatly appreciated.

You may want to add similar entry for jackson-core-asl -- mapper does
require core, and although there is transient dependency from mapper,
Maven does not necessarily enforce correct version.
So it is best to add explicit dependency so that version of core is
also 1.5.x; you may otherwise just get 1.0.1 of that one.

-+ Tatu +-
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB