Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # dev >> unable to run unit test in trunk against hadoop 2.0


Copy link to this message
-
Re: unable to run unit test in trunk against hadoop 2.0
>From this [1] build, it looks like one of these two introduced the problem
-- :

   1. HBASE-8266-Master cannot start if TableNotFoundException is thrown
   while partial table recovery(Ram)
(detail<http://54.241.6.143/job/HBase-TRUNK-Hadoop-2/org.apache.hbase$hbase-server/106/changes#detail0>
   )
   2. HBASE-8165 Update our protobuf to 2.5 from 2.4.1
(detail<http://54.241.6.143/job/HBase-TRUNK-Hadoop-2/org.apache.hbase$hbase-server/106/changes#detail1>
   )
Spent a minute to look at the errors, it looks like all of them are related
to protobuf -- looks like HBASE-8165 is the trigger.  Have you tried doing
a 'mvn instal' to upated the hbase-protocol module to see if that fixed the
problem?

[1]
http://54.241.6.143/job/HBase-TRUNK-Hadoop-2/org.apache.hbase$hbase-server/106/#showFailuresLink

On Wed, Apr 10, 2013 at 2:40 PM, Ted Yu <[EMAIL PROTECTED]> wrote:

> Jon:
> Looks like your workspace was out of date.
>
> Have you seen this (204 test failures) ?
>
> http://54.241.6.143/job/HBase-TRUNK-Hadoop-2/107/testReport/
>
> On Wed, Apr 10, 2013 at 2:37 PM, Jonathan Hsieh <[EMAIL PROTECTED]> wrote:
>
> > Hey Ted,
> >
> > I was working on fixing that particular unit test against hadoop2 this
> > morning in HBASE-7606 and it seems to work for me (after the patch.
> Before
> > the patch it tends to hang).  Are you running it like this:
> >
> > $ mvn clean test -Dhadoop.profile=2.0 -Dtest=TestJoinedScanners
> > ....
> > -------------------------------------------------------
> >  T E S T S
> > -------------------------------------------------------
> > Running org.apache.hadoop.hbase.regionserver.TestJoinedScanners
> > Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 63.813
> sec
> >
> >
> > Jon.
> >
> >
> > On Wed, Apr 10, 2013 at 2:01 PM, Ted Yu <[EMAIL PROTECTED]> wrote:
> >
> > > Hi,
> > > I am getting the following error when trying to run unit test in trunk
> > > against hadoop 2.0:
> > >
> > >
> >
> testJoinedScanners(org.apache.hadoop.hbase.regionserver.TestJoinedScanners)
> > >  Time elapsed: 2.518 sec  <<< ERROR!
> > > java.lang.UnsupportedOperationException: This is supposed to be
> > overridden
> > > by subclasses.
> > >   at
> > >
> > >
> >
> com.google.protobuf.GeneratedMessage.getUnknownFields(GeneratedMessage.java:180)
> > >   at
> > >
> > >
> >
> org.apache.hadoop.hdfs.protocol.proto.ClientNamenodeProtocolProtos$GetDatanodeReportRequestProto.getSerializedSize(ClientNamenodeProtocolProtos.java:21566)
> > >   at
> > >
> > >
> >
> com.google.protobuf.AbstractMessageLite.toByteString(AbstractMessageLite.java:49)
> > >   at
> > >
> > >
> >
> org.apache.hadoop.ipc.ProtobufRpcEngine$Invoker.constructRpcRequest(ProtobufRpcEngine.java:149)
> > >   at
> > >
> > >
> >
> org.apache.hadoop.ipc.ProtobufRpcEngine$Invoker.invoke(ProtobufRpcEngine.java:193)
> > >
> > > Looks like the above only happens with hadoop 2.0, not hadoop 1.0
> > >
> > > FYI
> > >
> >
> >
> >
> > --
> > // Jonathan Hsieh (shay)
> > // Software Engineer, Cloudera
> > // [EMAIL PROTECTED]
> >
>

--
// Jonathan Hsieh (shay)
// Software Engineer, Cloudera
// [EMAIL PROTECTED]