Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # dev >> Eclipse build broken?


Copy link to this message
-
Re: Eclipse build broken?
Would a symlink solve this issue cleanly? I'm not sure this solution would
work on Windows.
On Nov 30, 2012 11:42 AM, "Enis Söztutar" <[EMAIL PROTECTED]> wrote:

> From hbase-it/pom.xml:
>
>       <testResource>
>          <!-- We depend on hbase-server test resources -->
>         <directory>../hbase-server/src/test/resources</directory>
>       </testResource>
>
> We need this because, hbase-site.xml for tests is under
> hbase-server/src//test. Although hbase-it depends on hbase-server test-jar
> in the test scope, maven does not include the test resources (I think we
> exclude them from test-jar). So in order to execute tests in hbase-it with
> the hbase-site.xml stored in hbase-server/src/test/resources, I did put a
> dependency there.
>
> I cannot repro this easily. If the problem does not go away with
> eclipse:clean, can you file a jira.
>
> Enis
>
> On Fri, Nov 30, 2012 at 6:12 AM, Andrew Purtell <[EMAIL PROTECTED]>
> wrote:
>
> > path="/usr/src/Hadoop/hbase/hbase-server/src/test/resources"
> >
>
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB