Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Accumulo >> mail # dev >> Issues running Minicluster in o.a.a.start.Main


Copy link to this message
-
Re: Issues running Minicluster in o.a.a.start.Main
I have "accumulo minicluster" working now.   I changed the way MAC
determines what classpath to use.  I pushed a commit [1] to a branch on
github[2] if you want to take a look.  I am still experimenting with the
change.   I ran into some other bugs in master while working on this and
fixed those.  I also reopened ACCUMULO-1368 rather than opening a new
ticket.
[1]
https://github.com/keith-turner/accumulo/commit/1b9fbbc82a49e4939179f2f7b0b013517836b7f0
[2] https://github.com/keith-turner/accumulo/tree/ACCUMULO-1368
On Wed, Oct 9, 2013 at 8:52 PM, Corey Nolet <[EMAIL PROTECTED]> wrote:

> Looking at the commit history in master using gitk/gitx shows duplicated
> history. It looks like January through July 2013 occur at least twice in
> the commit history (with 2012 in between them). I'm suspecting this may
> have been why bisect wasn't working for me
>
>
>
> On Wed, Oct 9, 2013 at 1:25 PM, Keith Turner <[EMAIL PROTECTED]> wrote:
>
> > On Tue, Oct 8, 2013 at 9:45 PM, Corey Nolet <[EMAIL PROTECTED]> wrote:
> >
> > > Keith,
> > >
> > > It appears that the proxy's useMini and the minicluster command broke
> > > somewhere between
> > >
> > > 1edccf6b30541841bb08329317c6289aca8c8d73
> > > ACCUMULO-1707 applying Steve's patch
> > >
> > > and
> > >
> > > 98d7a9efc6d07e71d3803b3830bf9dc9ce8dec9d
> > > ACCUMULO-1558 made import table fail when files do not exist
> > >
> > > There was some weird merging happening during that sequence of commits.
> > At
> > > some point it looks like the master pom was set to version 1.5.1. If a
> > bug
> > > was fixed in this sequence of commits and the fix inherently broke the
> > > commands because they didn't belong in start.Main to begin with, I'm
> > > thinking it would probably be best to take the useMini property out of
> > the
> > > proxy and the minicluster command out of start.Main.
> > >
> > > If a bug was introduced, I'd like to get a ticket up for it.
> > >
> >
> > Yeah, go ahead and open a ticket.
> >
> >
> > >
> > >
> > >
> > >
> > >
> > > On Tue, Oct 8, 2013 at 12:02 AM, Corey Nolet <[EMAIL PROTECTED]>
> wrote:
> > >
> > > > Keith,
> > > >
> > > > You are right- I mistyped. I meant Main.err not Master.err. I just
> > > > verified this feature worked during the time of this
> > > > commit: 6965a8aaa2f53ec796a3487c1639affe0dfc6bfa.
> > > >
> > > >
> > > > On Mon, Oct 7, 2013 at 11:39 PM, Keith Turner <[EMAIL PROTECTED]>
> > wrote:
> > > >
> > > >> I just tried running "accumulo miniscluster" and saw the same thing.
> > >  But
> > > >> in Main.err, not Master.err are you sure you saw this in Master.err?
> > > >>
> > > >> Has this ever worked?   By default the accumulo scripts construct a
> > very
> > > >> minimal classpath w/ accumulo-start.jar,  log4j-1.2.15.jar, and the
> > conf
> > > >> dir.   If you modify the MAC exec method to print the classpath it
> > uses
> > > to
> > > >> start a java process, then you can see this.   MAC makes the
> > assumption
> > > >> that everything it needs is on the Java classpath, which is true
> when
> > > its
> > > >> run from Maven or Eclipse.  However when its run from the accumulo
> > > >> scripts,
> > > >> this is not true.
> > > >>
> > > >> Also, for some reason MAC starts zookeeper using Accumulo start
> main.
> >  I
> > > >> have no idea why its doing this.  Even if it was not doing this, I
> > think
> > > >> would fail in different way (i.e. instead of not finding VFS it
> would
> > > not
> > > >> find zookeeper class).
> > > >>
> > > >> Are you familiar with accumulo start module?
> > > >>
> > > >>
> > > >>
> > > >>
> > > >>
> > > >> On Mon, Oct 7, 2013 at 7:36 AM, Corey Nolet <[EMAIL PROTECTED]>
> > wrote:
> > > >>
> > > >> > The MiniAccumuloRunner class that's wired up to o.o.a.start.Main.
> > > >> >
> > > >> > I was specifically wondering if anyone else is experiencing issues
> > > >> running
> > > >> > 'accumulo minicluster' as both the proxy with useMini=true and the
> > > >> > minicluster command seem broken for me. I'm building from remote
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB