Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
MapReduce >> mail # user >> Re: Problems


Copy link to this message
-
答复: Problems
Please add "-server" in front of your JVM options
just a curiosity: why not using 64-bit version ?
________________________________________
发件人: Sean Hudson [[EMAIL PROTECTED]]
发送时间: 2013年1月17日 22:56
收件人: [EMAIL PROTECTED]
主题: Re: Problems

Hi,
      My Java version is

java version "1.6.0_25"
Java(TM) SE Runtime Environment (build 1.6.0_25-b06)
Java HotSpot(TM) Client VM (build 20.0-b11, mixed mode, sharing)

Would you advise obtaining a later Java version?

Sean

-----Original Message-----
From: Jean-Marc Spaggiari
Sent: Thursday, January 17, 2013 2:52 PM
To: [EMAIL PROTECTED]
Subject: Re: Problems

Hi Sean,

This is an issue with your JVM. Not related to hadoop.

Which JVM are you using, and can you try with the last from Sun?

JM

2013/1/17, Sean Hudson <[EMAIL PROTECTED]>:
> Hi,
>       I have recently installed hadoop-1.0.4 on a linux machine. Whilst
> working through the post-install instructions contained in the “Quick
> Start”
> guide, I incurred the following catastrophic Java runtime error (See
> below).
> I have attached the error report file “hs_err_pid24928.log”. I have
> submitted a Java bug report, but perhaps it is a known hadoop-1.0.4
> version
> problem.
>
> I am a first time user of Hadoop and would welcome guidance on this
> problem,
>
> Regards,
>
> Sean Hudson.
>
> shu@meath-nua:~/hadoop-1.0.4> bin/hadoop jar hadoop-examples-1.0.4.jar
> grep
> input output 'dfs[a-z.]+'
> #
> # A fatal error has been detected by the Java Runtime Environment:
> #
> #  SIGFPE (0x8) at pc=0xb7f2b1fb, pid=24928, tid=3074923424
> #
> # JRE version: 6.0_25-b06
> # Java VM: Java HotSpot(TM) Client VM (20.0-b11 mixed mode, sharing
> linux-x86 )
> # Problematic frame:
> # C  [ld-linux.so.2+0x91fb]  double+0xab
> #
> # An error report file with more information is saved as:
> # /home/shu/hadoop-1.0.4/hs_err_pid24928.log
> #
> # If you would like to submit a bug report, please visit:
> #   http://java.sun.com/webapps/bugreport/crash.jsp
> # The crash happened outside the Java Virtual Machine in native code.
> # See problematic frame for where to report the bug.
> #
> Aborted
> --
> Ostia Software Solutions Limited, 6 The Mill Building, The Maltings, Bray,
> Co. Wicklow, Ireland
>
> Registered in Ireland CRO No.507541 This email and any attachments to it
> is, unless otherwise stated, confidential, may contain copyright material
> and is for the use of the intended recipient only. If you have received
> this email in error, please notify the sender by return and deleting all
> copies. Any views expressed in this email are those of the sender and do
> not form part of any contract between Ostia Software Solutions Limited and
> any other party.
>
--
Ostia Software Solutions Limited, 6 The Mill Building, The Maltings, Bray,
Co. Wicklow, Ireland

Registered in Ireland CRO No.507541 This email and any attachments to it
is, unless otherwise stated, confidential, may contain copyright material
and is for the use of the intended recipient only. If you have received
this email in error, please notify the sender by return and deleting all
copies. Any views expressed in this email are those of the sender and do
not form part of any contract between Ostia Software Solutions Limited and
any other party.
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB