Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> Configuration setup


Copy link to this message
-
Re: Configuration setup
On Mon, Nov 26, 2012 at 2:16 PM, Mohit Anchlia <[EMAIL PROTECTED]> wrote:
> I have a need to move hbas-site.xml to an external location. So in order to
> do that I changed my configuration as shown below. But this doesn't seem to
> be working. It picks up the file but I get error, seems like it's going to
> the localhost. I checked hbase-site.xml in the directory and the zookeeper
> nodes are correctly listed.
>
>
> [11/26/2012 14:09:31,480] INFO apache.zookeeper.ClientCnxn
> [[web-analytics-ci-1.0.0-SNAPSHOT].AsyncFlow.async2.02-SendThread(localhost.localdomain:2181)]():
> Opening socket connection to server localhost.localdomain/127.0.0.1:2181
>
> -----
>
> changed from
>
> HBaseConfiguration.create()
>
> to
>
>
> config = *new* Configuration();
>
> config.addResource(*new* Path(*CONF_FILE_PROP_NAME*));
>
> *log*.info("Config location picked from:" + prop);
The above looks basically right but IIRC, this stuff can be tricky
adding in new resources and making sure stuff is applied in order --
and then there is 'final' configs that are applied after yours.

You could try copying the hbase conf dir to wherever, amending it to
suit your needs and then when starting hbase, add '--config
ALTERNATE_CONF_DIR'.

St.Ack
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB