Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase >> mail # user >> standalone HBase instance fails to start


+
matan 2012-11-24, 08:46
Copy link to this message
-
Re: standalone HBase instance fails to start
Just try adding this entry alone in your local host

127.0.0.1  'hostname'

and then try.. Recently i faced this problem and it got resolved.

Regards
Ram

On Sat, Nov 24, 2012 at 2:16 PM, matan <[EMAIL PROTECTED]> wrote:

> Hi,
>
> My standalone HBase instance, installed as per the 'getting started'
> section
> at  http://hbase.apache.org/book/quickstart.html, doesn't work insofar.
>
> I get in the log file:
>
> 2012-11-23 18:26:37,827 INFO org.apache.zookeeper.ClientCnxn: Session
> establishment complete on server localhost/127.0.0.1:2181, sessionid = 0x1
> 3b2e17842c0002, negotiated timeout = 40000
> 2012-11-23 18:26:37,866 INFO org.apache.hadoop.ipc.HBaseRPC: Server at
> localhost/127.0.0.1:39699 could not be reached after 1 tries, giving up.
> 2012-11-23 18:26:37,867 WARN
> org.apache.hadoop.hbase.master.AssignmentManager: Failed assignment of
> -ROOT-,,0.70236052 to localhost,39699,135368
> 7992912, trying to assign elsewhere instead; retry=0
> org.apache.hadoop.hbase.client.RetriesExhaustedException: Failed setting up
> proxy interface org.apache.hadoop.hbase.ipc.HRegionInterface to loca
> lhost/127.0.0.1:39699 after attempts=1
> .
> .
> .
> 2012-11-23 18:26:37,869 WARN
> org.apache.hadoop.hbase.master.AssignmentManager: Unable to find a viable
> location to assign region -ROOT-,,0.70236
> 052
> 2012-11-23 18:29:53,157 ERROR
> org.apache.hadoop.hbase.master.HMasterCommandLine: Failed to start masterv
>
> This is on an Ubuntu 12.04 LTS VirtualBox, 1GB Memory, 10GB free disk
> space,
> with Oracle JRE 1.6.0_37.
>
> I found some workarounds talking about /etc/hosts but am not sure whether
> they are relevant. My etc/hosts contains only:
>
> ::1     ip6-localhost ip6-loopback
> fe00::0 ip6-localnet
> ff00::0 ip6-mcastprefix
> ff02::1 ip6-allnodes
> ff02::2 ip6-allrouters
>
> I'm really stuck here.
> Any help would be very much appreciated! Thanks!
> I also posted this at  stackoverflow
> <http://stackoverflow.com/questions/13533283/hbase-fails-to-start>
> before
> finding this mailing list (... promise to update both when I have it
> resolved)
>
>
>
> --
> View this message in context:
> http://apache-hbase.679495.n3.nabble.com/standalone-HBase-instance-fails-to-start-tp4034333.html
> Sent from the HBase User mailing list archive at Nabble.com.
>
+
matan 2012-11-24, 11:23
+
Jean-Marc Spaggiari 2012-11-24, 12:40
+
matan 2012-11-24, 16:41
+
Stack 2012-11-25, 03:53
+
matan 2012-11-24, 17:45
+
Stack 2012-11-25, 05:10
+
Stack 2012-11-26, 17:44