Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
Kafka, mail # dev - Are we doing a 0.7.2?


Copy link to this message
-
Re: Are we doing a 0.7.2?
Chris Burroughs 2012-07-26, 12:31
Would management of these concurrent branches be significantly easier if
we switched from svn to git?

On 07/18/2012 07:01 PM, Jay Kreps wrote:
> Cool, then I guess we can go case by case on double-checkins to trunk and
> 0.8.
>
> -Jay
>
> On Wed, Jul 18, 2012 at 1:13 PM, Neha Narkhede <[EMAIL PROTECTED]>wrote:
>
>> I think it might be useful for the community to have a couple more releases
>> for 0.7.*, at least until 0.8 is fully stable.
>>
>> Thanks,
>> Neha
>>
>> On Wed, Jul 18, 2012 at 1:03 PM, Chris Burroughs
>> <[EMAIL PROTECTED]>wrote:
>>
>>> I added a 0.7.2 release in JIRA for you (Joe, do you have the bits
>>> flipped to be able to do this?)
>>>
>>> On 07/18/2012 02:05 PM, Joe Stein wrote:
>>>> I was thinking we would have a 0.7.2 release if there are patches in
>>> trunk
>>>> that folks want to use, why not release them and make it available for
>>>> them?  I don't mind doing releases ... double commits make this
>>> manageable
>>>>
>>>> 0.7.X off trunk, yup
>>>>
>>>> On Wed, Jul 18, 2012 at 1:27 PM, Joel Koshy <[EMAIL PROTECTED]>
>> wrote:
>>>>
>>>>> 0.7.1 patch == patch to apply on branch 0.7.1 or trunk? I thought we
>>> would
>>>>> be doing double-commits on trunk and 0.8 and not worry about release
>>>>> branches for now. Also, 0.7.2 would be cut off trunk. (Both 0.7.1 and
>>> 0.7
>>>>> were cut off trunk.)
>>>>>
>>>>> Joel
>>>>>
>>>>>
>>>>> On Wed, Jul 18, 2012 at 10:19 AM, Jay Kreps <[EMAIL PROTECTED]>
>>> wrote:
>>>>>
>>>>>> People tend to produce patches against the 0.7.1. Currently I think
>> we
>>>>> are
>>>>>> urging double commits on trunk and 0.8 because the large code
>>> difference
>>>>>> makes auto merges too dangerous. However I don't think we are likely
>> to
>>>>> do
>>>>>> a 0.7.2 release (0.8 is not too far out at this point). So I think we
>>>>>> should be advising people to giving any non-critical patches just
>>> against
>>>>>> 0.8, right?
>>>>>>
>>>>>> Thoughts?
>>>>>>
>>>>>> -Jay
>>>>>>
>>>>>
>>>>
>>>>
>>>>
>>>
>>>
>>
>