Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Pig >> mail # user >> pig-0.10.0: TestJobSubmission failed with: Internal error creating job configuration.


+
lulynn_2008 2012-08-15, 07:56
+
Cheolsoo Park 2012-08-15, 17:30
+
lulynn_2008 2012-08-17, 06:02
+
Cheolsoo Park 2012-08-18, 06:26
+
lulynn_2008 2012-08-20, 03:01
+
lulynn_2008 2012-08-21, 07:24
Copy link to this message
-
Re: Re: Re: pig-0.10.0: TestJobSubmission failed with: Internal error creating job configuration.
Hi,

TestJobSubmission doesn't pass for me either. But it doesn't throw the
error that you're seeing. Instead, it hangs at line 583
in TestJobSubmission.java. I am not sure yet what's happening though.

Thanks,
Cheolsoo

On Tue, Aug 21, 2012 at 12:24 AM, lulynn_2008 <[EMAIL PROTECTED]> wrote:

> Hi Cheolsoo,
> Please help to check whether TestJobSunbmission passed in your
> environment. Thanks
>
>
> Hi Cheolsoo,
> TestHBaseStorage passed now with your fix. Thanks.
> But TestJobSubmission still failed with the same previous error with
> TestHBaseStorage. Please help to check. Thanks
>
>
>
>
>
> At 2012-08-18 14:26:32,"Cheolsoo Park" <[EMAIL PROTECTED]> wrote:
> >Hi,
> >
> >I tried the same version of libraries as you're using and was able to get
> >TestHBaseStorage passing in trunk. Here is what I did:
> >
> >1) Updated the version of hadoop, hbase, and zookeeper in
> >ivy/libraries.properties:
> >
> >hadoop-core.version=1.0.3
> >> hadoop-test.version=1.0.3
> >> hbase.version=0.94.0
> >> zookeeper.version=3.4.3
> >
> >
> >2) Updated TestHBaseStorage.java since it doesn't compile with
> hbase-0.94.0:
> >
> >HTable table = new HTable(tableName); => HTable table = new HTable(conf,
> >> tableName);
> >
> >
> >There are 6 places to fix.
> >
> >3) Added the following lines to ivy.xml:
> >
> ><dependency org="com.github.stephenc.high-scale-lib" name="high-scale-lib"
> >> rev="${high-scale-lib.version}" conf="test->default"/>
> >> <dependency org="com.google.protobuf" name="protobuf-java"
> >> rev="${protobuf-java.version}" conf="test->default"/>
> >
> >
> >I also added the following line to ivy/libraries.properties:
> >
> >high-scale-lib.version=1.1.1
> >
> >
> >In particular, I was able to reproduce your error without this line in
> >ivy.xml:
> >
> ><dependency org="com.google.protobuf" name="protobuf-java"
> >> rev="${protobuf-java.version}" conf="test->default"/>
> >
> >
> >With all these changes, TestHBaseStorage passes for me. Please let me know
> >if this works for you.
> >
> >Thanks,
> >Cheolsoo
> >
> >On Thu, Aug 16, 2012 at 11:02 PM, lulynn_2008 <[EMAIL PROTECTED]>
> wrote:
> >
> >> BTW, I am using hadoop-1.0.3, hbase-0.94.0 and zookeeper-3.4.3.
> >>
> >>
> >> Hi Cheolsoo,
> >> You are right. TestHBaseStorage also failed with the same error.
> >>
> >> I got following region server information, and seems hbase region has
> been
> >> started successfully. But hbase can not connect to zookeeper
> >>
> >> 12/08/13 06:34:12 INFO server.PrepRequestProcessor: Got user-level
> >> KeeperException when processing sessionid:0x1391cf90aed0000 type:delete
> >> cxid:0x24 zxid:0x10 txntype:-1 reqpath:n/a Error
> >> Path:/hbase/root-region-server Error:KeeperErrorCode = NoNode for
> >> /hbase/root-region-server
> >>
> >> 12/08/13 06:34:16 INFO regionserver.HRegion: creating HRegion pigtable_1
> >> HTD == {NAME => 'pigtable_1', FAMILIES => [{NAME => 'pig',
> >> REPLICATION_SCOPE => '0', KEEP_DELETED_CELLS => 'false', COMPRESSION =>
> >> 'NONE', ENCODE_ON_DISK => 'true', BLOCKCACHE => 'true', MIN_VERSIONS =>
> >> '0', DATA_BLOCK_ENCODING => 'NONE', IN_MEMORY => 'false', BLOOMFILTER =>
> >> 'NONE', TTL => '2147483647', VERSIONS => '3', BLOCKSIZE => '65536'}]}
> >> RootDir = hdfs://shihc015:54670/user/root/hbase Table name == pigtable_1
> >>
> >> 12/08/13 06:34:43 INFO zookeeper.ClientCnxn: Opening socket connection
> to
> >> server shihc015/127.0.0.1:21818
> >> 12/08/13 06:34:43 WARN client.ZooKeeperSaslClient: SecurityException:
> >> java.lang.SecurityException: Unable to locate a login configuration
> >> occurred when trying to find JAAS configuration.
> >> 12/08/13 06:34:43 INFO client.ZooKeeperSaslClient: Client will not
> >> SASL-authenticate because the default JAAS configuration section
> 'Client'
> >> could not be found. If you are not using SASL, you may ignore this. On
> the
> >> other hand, if you expected SASL to work, please fix your JAAS
> >> configuration.
> >> 12/08/13 06:34:43 WARN zookeeper.ClientCnxn: Session 0x0 for server
+
Cheolsoo Park 2012-08-21, 21:51
+
lulynn_2008 2012-08-22, 02:55
+
lulynn_2008 2012-08-17, 05:59