Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
MapReduce >> mail # user >> Hadoop LZO compression class not found error in Pig 0.11


Copy link to this message
-
Hadoop LZO compression class not found error in Pig 0.11
Hi all,

I'm trying to upgrade pig version to pig-0.11, but getting error in
java.lang. IllegalArgumentException: Compression codec
com.hadoop.compression.lzo.LzoCodec not found

While submitting the query, I got success msg as follows but getting the
above error in final stage,

2013-07-27 17:14:30,612 [Thread-6] INFO com.hadoop.compression.lzo.LzoCodec
-Successfully loaded & initialized native-lzo library [hadoop-lzo rev
cc0cdbdae8422d5f11096d033c4e6e0324f231f6]

Even I have copied the hadoop gpl lzo native library and created symbolic
link in pig lib folder.

Do I need to compile the hadoop for the pig version? There are two pig jars
in pig lib?

I have specified the lzo property in core-site.xml conf.

How to solve this?

Please help on this.
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB