Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
MapReduce >> mail # user >> Re: Hadoop 2.0.4: Unable to load native-hadoop library for your platform


Copy link to this message
-
Re: Hadoop 2.0.4: Unable to load native-hadoop library for your platform
The native libraries packed in a binary tarball of 2.0.4 may not apply
to all OSes and architectures. You will need to build your own native
libraries to make sure they are appropriate for your servers/clients.

Instructions for native builds are available in the downloaded
tarball's src/BUILDING.txt file.

An alternative, and a much simpler way, is to use Apache Bigtop
(http://bigtop.apache.org) which can build packages for you on almost
any popular OS today, and it also includes the right native libs in
the package.

On Fri, May 24, 2013 at 11:05 AM, Ben Kim <[EMAIL PROTECTED]> wrote:
> Hi I downloaded hadoop 2.0.4 and keep getting these errors from hadoop cli
> and MapReduce task logs
>
> 13/05/24 14:34:17 WARN util.NativeCodeLoader: Unable to load native-hadoop
> library for your platform... using builtin-java classes where applicable
>
> i tried adding $HADOOP_HOME/lib/native/* to CLASSPATH and LD_LIBRARY_PATH
> but none of these worked.
>
> Had anyone have similar problem?
>
> TY!
>
> --
>
> Benjamin Kim
> benkimkimben at gmail

--
Harsh J
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB