Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Accumulo >> mail # dev >> dependencies within 1.5


+
Jim Klucar 2013-05-20, 02:10
+
Christopher 2013-05-20, 04:06
+
Corey Nolet 2013-05-20, 11:49
+
David Medinets 2013-05-20, 12:11
+
Corey Nolet 2013-05-20, 12:21
+
Corey Nolet 2013-05-20, 12:44
+
Jim Klucar 2013-05-20, 13:10
+
John Vines 2013-05-20, 14:24
+
Christopher 2013-05-20, 16:52
+
Christopher 2013-05-20, 17:56
+
Corey Nolet 2013-05-20, 18:00
+
Christopher 2013-05-20, 18:09
+
Corey Nolet 2013-05-20, 18:10
+
Corey Nolet 2013-05-21, 16:16
Copy link to this message
-
Re: dependencies within 1.5
On Tue, May 21, 2013 at 12:16 PM, Corey Nolet <[EMAIL PROTECTED]> wrote:

> I think it's worth asking because a few people expressed interest in moving
> the mini cluster to it's own module. Do we want this for 1.5 or do we wait
> until 1.6 and provide a deprecation strategy?
>

I think we should move it in 1.5 XOR leave the package name the same in
1.6, but move it to another module.  Either way avoids API changes for
users.

>
>
> On Mon, May 20, 2013 at 2:10 PM, Corey Nolet <[EMAIL PROTECTED]> wrote:
>
> > Agreed, they also slow down the build.
> >
> >
> > On Mon, May 20, 2013 at 2:09 PM, Christopher <[EMAIL PROTECTED]>
> wrote:
> >
> >> Maybe...  or 'jar-with-dependencies' assembly, or something similar,
> >> might be useful.
> >> I'd probably argue for it to be in a de-activated profile, by default,
> >> though. Shaded jars can become problematic if people start using them
> >> as dependencies.
> >>
> >> --
> >> Christopher L Tubbs II
> >> http://gravatar.com/ctubbsii
> >>
> >>
> >> On Mon, May 20, 2013 at 2:00 PM, Corey Nolet <[EMAIL PROTECTED]> wrote:
> >> > This may be far out into space- but how would you guys feel about
> >> providing
> >> > a shaded jar in the pom for a new mini module? This may make it easier
> >> for
> >> > users to run the mini accumulo cluster without hadoop/zookeeper
> >> installed.
> >> >
> >> >
> >> > On Mon, May 20, 2013 at 1:56 PM, Christopher <[EMAIL PROTECTED]>
> >> wrote:
> >> >
> >> >> ACCUMULO-1436 for fixing "provided" dependencies.
> >> >>
> >> >> --
> >> >> Christopher L Tubbs II
> >> >> http://gravatar.com/ctubbsii
> >> >>
> >> >>
> >> >> On Mon, May 20, 2013 at 12:52 PM, Christopher <[EMAIL PROTECTED]>
> >> wrote:
> >> >> > You're right. I'm not sure why our internal dependencies would be
> >> >> > marked as provided... except maybe I made that mistake to try to
> deal
> >> >> > with the mess of the 'copy-dependencies' stuff. That should be
> fixed.
> >> >> >
> >> >> > --
> >> >> > Christopher L Tubbs II
> >> >> > http://gravatar.com/ctubbsii
> >> >> >
> >> >> >
> >> >> > On Mon, May 20, 2013 at 10:24 AM, John Vines <[EMAIL PROTECTED]>
> >> wrote:
> >> >> >> Jim, accumulo-start is a provided dependency for all of the other
> >> >> versions.
> >> >> >> So when you list accumulo-server as a dependency, it does not pull
> >> in
> >> >> the
> >> >> >> provided dependencies.
> >> >> >>
> >> >> >> This is sort of what I was getting at before, Chris. The provided
> >> jars
> >> >> >> don't get pulled in/referenced when they are marked as provided.
> For
> >> >> >> external dependencies, that totally makes sense. But I don't know
> >> why we
> >> >> >> need to mark other accumulo parts as provided. I find it difficult
> >> to
> >> >> >> believe that that is a standard maven configuration. It is
> extremely
> >> >> >> painful for downstream clients.
> >> >> >>
> >> >> >>
> >> >> >> On Mon, May 20, 2013 at 9:10 AM, Jim Klucar <[EMAIL PROTECTED]>
> >> wrote:
> >> >> >>
> >> >> >>> The question mark was in my statement because I didn't actually
> >> know
> >> >> if it
> >> >> >>> created a circular dependency. It appears that Corey found it
> >> doesn't
> >> >> have
> >> >> >>> one. All I did was put a dependency on accumulo-master and saw
> that
> >> >> when I
> >> >> >>> did so, Maven didn't pull accumulo-start for me. From my
> >> understanding,
> >> >> >>> that is the whole point of Maven, to handle the sub-dependencies
> of
> >> >> what
> >> >> >>> I'm trying to use and when I tried to use MiniAccumuloCluster, it
> >> >> didn't
> >> >> >>> pull all the right dependencies.
> >> >> >>>
> >> >> >>>
> >> >> >>> On Mon, May 20, 2013 at 8:44 AM, Corey Nolet <[EMAIL PROTECTED]>
> >> >> wrote:
> >> >> >>>
> >> >> >>> > I take that back- the start module does not have an explicit
> >> >> dependency
> >> >> >>> on
> >> >> >>> > accumulo-server. As long as the Main.class is used from the
> >> assembly
> >> >> >>> > artifact's classpath, everything should work fine.
> >> >> >>> >
> >> >> >>> >
+
Corey Nolet 2013-05-21, 16:36
+
John Vines 2013-05-21, 16:34
+
Keith Turner 2013-05-21, 16:36
+
Christopher 2013-05-21, 16:50
+
Corey Nolet 2013-05-21, 17:30
+
John Vines 2013-05-21, 17:35
+
Christopher 2013-05-21, 18:08
+
Corey Nolet 2013-05-20, 18:02
+
Ed Kohlwey 2013-05-20, 15:50
+
Josh Elser 2013-05-20, 17:12
+
Christopher 2013-05-20, 17:37
+
Corey Nolet 2013-05-20, 17:52