Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
Hadoop >> mail # user >> Hbase  with Hadoop


+
Jignesh Patel 2011-10-11, 21:11
+
Matt Foley 2011-10-12, 00:13
+
jigneshmpatel 2011-10-12, 03:29
+
Konstantin Boudnik 2011-10-12, 04:54
+
Vinod Gupta Tankala 2011-10-12, 15:58
+
Jignesh Patel 2011-10-12, 16:26
+
Vinod Gupta Tankala 2011-10-12, 16:31
+
Jignesh Patel 2011-10-12, 18:39
+
Jignesh Patel 2011-10-12, 19:19
+
Jignesh Patel 2011-10-12, 20:47
+
Matt Foley 2011-10-12, 23:50
+
Ramya Sunil 2011-10-13, 03:51
+
giridharan kesavan 2011-10-13, 06:02
+
Jignesh Patel 2011-10-13, 16:34
+
jigneshmpatel 2011-10-13, 15:30
+
jigneshmpatel 2011-10-13, 15:50
+
Harsh J 2011-10-13, 17:32
+
Matt Foley 2011-10-13, 17:33
+
Ramya Sunil 2011-10-13, 17:34
+
Jignesh Patel 2011-10-13, 19:01
+
Ramya Sunil 2011-10-13, 19:23
+
Jignesh Patel 2011-10-13, 19:37
+
Ramya Sunil 2011-10-13, 20:53
+
Jignesh Patel 2011-10-13, 21:40
+
Jignesh Patel 2011-10-13, 23:11
Copy link to this message
-
Re: Hbase with Hadoop
Jignesh,

I have been able to deploy Hbase 0.90.3 and 0.90.4 with hadoop-0.20.205.
Below are the steps I followed:

1. Make sure none of hbasemaster, regionservers or zookeeper are running. As
Matt pointed out, turn on append.
2. hbase-daemon.sh --config $HBASE_CONF_DIR start zookeeper
3. hbase-daemon.sh --config $HBASE_CONF_DIR start master
4. hbase-daemon.sh --config $HBASE_CONF_DIR start regionserver
5. hbase --config $HBASE_CONF_DIR shell
Hope it helps.
Ramya

On Thu, Oct 13, 2011 at 4:11 PM, Jignesh Patel <[EMAIL PROTECTED]> wrote:

> Is there a way to resolve this weird problem.
>
> > bin/hbase-start.sh is supposed to start zookeeper but it doesn't start.
> But on the other side if zookeeper up and running then it says
>
> > Couldnt start ZK at requested address of 2181, instead got: 2182.
> Aborting. Why? Because clients (eg shell) wont be able to find this ZK
> quorum
>
>
>
> On Oct 13, 2011, at 5:40 PM, Jignesh Patel wrote:
>
> > Ok now the problem is
> >
> > if I only use bin/hbase-start.sh then it doesn't start zookeeper.
> >
> > But if I use bin/hbase-daemon.sh start zookeeper before starting
> bin/hbase-start.sh then it will try to start zookeeper at port 2181 and then
> I have following error.
> >
> > Couldnt start ZK at requested address of 2181, instead got: 2182.
> Aborting. Why? Because clients (eg shell) wont be able to find this ZK
> quorum
> >
> >
> > So I am wondering if bin/hbase-start.sh is trying to start zookeeper then
> while zookeeper is not running it should start the zookeeper. I only get the
> error if zookeeper already running.
> >
> >
> > -Jignesh
> >
> >
> > On Oct 13, 2011, at 4:53 PM, Ramya Sunil wrote:
> >
> >> You already have zookeeper running on 2181 according to your jps output.
> >> That is the reason, master seems to be complaining.
> >> Can you please stop zookeeper, verify that no daemons are running on
> 2181
> >> and restart your master?
> >>
> >> On Thu, Oct 13, 2011 at 12:37 PM, Jignesh Patel <[EMAIL PROTECTED]>
> wrote:
> >>
> >>> Ramya,
> >>>
> >>>
> >>> Based on "Hbase the definite guide" it seems zookeeper being started by
> >>> hbase no need to start it separately(may be this is changed for 0.90.4.
> >>> Anyways now  following is the updated status.
> >>>
> >>> Jignesh-MacBookPro:hadoop-hbase hadoop-user$ bin/start-hbase.sh
> >>> starting master, logging to
> >>>
> /users/hadoop-user/hadoop-hbase/logs/hbase-hadoop-user-master-Jignesh-MacBookPro.local.out
> >>> Couldnt start ZK at requested address of 2181, instead got: 2182.
> Aborting.
> >>> Why? Because clients (eg shell) wont be able to find this ZK quorum
> >>> Jignesh-MacBookPro:hadoop-hbase hadoop-user$ jps
> >>> 41486 HQuorumPeer
> >>> 38814 SecondaryNameNode
> >>> 41578 Jps
> >>> 38878 JobTracker
> >>> 38726 DataNode
> >>> 38639 NameNode
> >>> 38964 TaskTracker
> >>>
> >>> On Oct 13, 2011, at 3:23 PM, Ramya Sunil wrote:
> >>>
> >>>> Jignesh,
> >>>>
> >>>> I dont see zookeeper running on your master. My cluster reads the
> >>> following:
> >>>>
> >>>> $ jps
> >>>> 15315 Jps
> >>>> 13590 HMaster
> >>>> 15235 HQuorumPeer
> >>>>
> >>>> Can you please shutdown your Hmaster and run the following first:
> >>>> $ hbase-daemon.sh start zookeeper
> >>>>
> >>>> And then start your hbasemaster and regionservers?
> >>>>
> >>>> Thanks
> >>>> Ramya
> >>>>
> >>>> On Thu, Oct 13, 2011 at 12:01 PM, Jignesh Patel <[EMAIL PROTECTED]>
> >>> wrote:
> >>>>
> >>>>> ok --config worked but it is showing me same error. How to resolve
> this.
> >>>>>
> >>>>> http://pastebin.com/UyRBA7vX
> >>>>>
> >>>>> On Oct 13, 2011, at 1:34 PM, Ramya Sunil wrote:
> >>>>>
> >>>>>> Hi Jignesh,
> >>>>>>
> >>>>>> "--config" (i.e. - - config) is the option to use and not "-config".
> >>>>>> Alternatively you can also set HBASE_CONF_DIR.
> >>>>>>
> >>>>>> Below is the exact command line:
> >>>>>>
> >>>>>> $ hbase --config /home/ramya/hbase/conf shell
> >>>>>> hbase(main):001:0> create 'newtable','family'
> >>>>>> 0 row(s) in 0.5140 seconds
> >>>>>>
> >>
+
Jignesh Patel 2011-10-14, 14:44
+
Todd Lipcon 2011-10-14, 20:02
+
Jignesh Patel 2011-10-14, 18:46
+
Jignesh Patel 2011-10-14, 19:35
+
Jignesh Patel 2011-10-14, 21:16
+
Jignesh Patel 2011-10-14, 21:38
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB