Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hive >> mail # user >> Does hive REAL enable TestHadoop20SAuthBridge in hive-0.8.0 ? -- [HIVE-2257] patch doesn't work for me


Copy link to this message
-
Does hive REAL enable TestHadoop20SAuthBridge in hive-0.8.0 ? -- [HIVE-2257] patch doesn't work for me
Hi, All
When I ran hive UT, I found that TestHadoop20SAuthBridge wasn't compiled,
so TestHadoop20SAuthBridge won't be run by "ant test" command.

In src/shims/build.xml, I found the following lines:

  <target name="compile-test" depends="compile">
    <echo message="Project: ${ant.project.name}"/>
    <!-- TODO: move tests to version directory -->
    <!--antcall target="compile_secure_test" inheritRefs="false"
inheritAll="false">
      <param name="hadoop.version.ant-internal"
value="${hadoop.security.version}" />
      <param name="hadoop.version.ant-internal.prefix"
value="${hadoop.security.version.prefix}" />
    </antcall-->
  </target>

Then, I commented off lines in blue, and it could generate the class file
of TestHadoop20SAuthBridge.
But if I change the security hadoop version to 1.0.0, it failed with:

build_shims:
     [echo] Project: shims
     [echo] Compiling shims against hadoop 1.0.1-SNAPSHOT
(/home/libing/Round-1/hive-0.8.0/src/build/hadoopcore/IHC-1.0.1-SNAPSHOT)

BUILD FAILED
/home/libing/Round-1/hive-0.8.0/src/build.xml:307: The following error
occurred while executing this line:
/home/libing/Round-1/hive-0.8.0/src/build.xml:325: The following error
occurred while executing this line:
/home/libing/Round-1/hive-0.8.0/src/shims/build.xml:76: The following error
occurred while executing this line:
/home/libing/Round-1/hive-0.8.0/src/shims/build.xml:66: srcdir
"/home/libing/Round-1/hive-0.8.0/src/shims/src/1.0/java" does not exist!
Does it mean that if we want to use a hadoop as hadoop.security.version, we
should keep a directory in shims/src/xxx by ourselves as well?
Thanks,
- Bing
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB