Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
Accumulo, mail # user - Table deletion got stuck


+
Lin XIAO 2012-11-27, 21:28
+
Keith Turner 2012-11-27, 21:38
+
Lin XIAO 2012-11-27, 21:42
+
Keith Turner 2012-11-27, 22:22
+
John Vines 2012-11-27, 22:24
+
Lin XIAO 2012-11-27, 23:20
+
Keith Turner 2012-11-28, 13:55
+
Lin XIAO 2012-11-28, 15:44
+
Keith Turner 2012-11-28, 15:55
+
Lin XIAO 2012-11-28, 16:07
+
Keith Turner 2012-11-28, 16:20
+
Lin XIAO 2012-11-28, 19:22
+
Keith Turner 2012-11-29, 18:16
+
Keith Turner 2012-11-28, 16:08
+
Lin XIAO 2012-11-28, 19:05
Copy link to this message
-
Re: Table deletion got stuck
Keith Turner 2012-11-28, 16:56
On Tue, Nov 27, 2012 at 4:28 PM, Lin XIAO <[EMAIL PROTECTED]> wrote:

> When deleting tables, sometimes the operation get stuck for hours with
> table status "UNKNOWN" shown in the monitor page. The only relevant
> logs I can find are similar to this:
>
> [tableOps.CleanUp] DEBUG: Still waiting for table to be deleted: is
> locationState: is<<@(null,10.0.0.10:41000[43b1b039a081368],null)
>
> It happens to a few tables in our cluster and most of them are hosted
> by one tablet server, so I killed the tablet server to force the
> tablets to be reassigned to other servers. The tables got deleted
>

In the future save the output of running jstack on the tablet server before
killing it.
> successfully after that. I'm wondering what I should do to solve
> problems like this. Right now, we still have a bunch of tables with
> status "UNKNOWN". I'm wondering if I need to find the tablet servers
> hosting those tables and restart them.
>
> Btw, the swappiness in our cluster is set to 60 now instead of the
> recommended value 10.
>
> Thanks,
> Lin
>