Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase, mail # user - HBase Java client - unknown host: localhost.localdomain


Copy link to this message
-
Re: HBase Java client - unknown host: localhost.localdomain
Kevin O'dell 2013-08-25, 14:22
Shengjie,

  Good news on being able to connect to the ui from the client. Can you
post a screen shot on imgur?
On Aug 25, 2013 10:12 AM, "Jean-Marc Spaggiari" <[EMAIL PROTECTED]>
wrote:

> Can you share your client code? Or at least the section where you do the
> connection?
>
> Also, have you tried to run the same code from inside the VM?
>
> JM
>
> 2013/8/25 Shengjie Min <[EMAIL PROTECTED]>
>
> > Hi Jean-Marc,
> >
> > Sorry about the screenshot, yes, my Hbase client is outside of my VM.
> And I
> > can access WebUI from outside: http://cloudera:60010
> >
> > Shengjie
> >
> >
> > On 25 August 2013 21:43, Jean-Marc Spaggiari <[EMAIL PROTECTED]
> > >wrote:
> >
> > > I think you need to post the screenshot on an external website and send
> > the
> > > link here.
> > >
> > > So, you are trying to access your VM from outside of your VM? Or your
> > > client application is into the VM too?
> > >
> > > If you are outside of your VM, are you able to access the VM from
> > outside?
> > >
> > > Like, are you able to access the WebUI from outside of the VM with
> > > something like "http://cloudera:60010"?
> > >
> > > JM
> > >
> > > 2013/8/25 Shengjie Min <[EMAIL PROTECTED]>
> > >
> > > >
> > > >
> > > >
> > > > On 25 August 2013 21:08, Kevin O'dell <[EMAIL PROTECTED]>
> > wrote:
> > > >
> > > >> Can you attach a screen shot of the HMaster UI? It appears ZK is
> > > >> connecting
> > > >> fine, but can't find .META.
> > > >> On Aug 25, 2013 8:57 AM, "Shengjie Min" <[EMAIL PROTECTED]>
> > wrote:
> > > >>
> > > >> > Hi Jean-Marc,
> > > >> >
> > > >> > You meant my cloudera vm or my client? Here is my /etc/hosts
> > > >> >
> > > >> > cloudera vm:
> > > >> >
> > > >> > 127.0.0.1   localhost.localdomain   localhost
> > > >> >
> > > >> > client:
> > > >> > 127.0.0.1       localhost
> > > >> > 255.255.255.255 broadcasthost
> > > >> > ::1             localhost
> > > >> > fe80::1%lo0     localhost
> > > >> >
> > > >> > 172.16.144.150  cloudera
> > > >> >
> > > >> >
> > > >> > Shengjie
> > > >> >
> > > >> >
> > > >> > On 25 August 2013 20:28, Jean-Marc Spaggiari <
> > [EMAIL PROTECTED]
> > > >> > >wrote:
> > > >> >
> > > >> > > Hi,
> > > >> > >
> > > >> > > Do you have your host+ip in your host file?
> > > >> > >
> > > >> > > JM
> > > >> > >
> > > >> > > 2013/8/25 Shengjie Min <[EMAIL PROTECTED]>
> > > >> > >
> > > >> > > > Hi guys,
> > > >> > > >
> > > >> > > > I am running cloudera quick start vm:
> > > >> > > >
> > > >> > > > Versions:
> > > >> > > >
> > > >> > > > Hadoop: 2.0.0-cdh4.3.1
> > > >> > > >
> > > >> > > > HBase: 0.94.6-cdh4.3.1
> > > >> > > >
> > > >> > > > Here is my little remote HBase Java client(HbaseClient.java),
> > all
> > > it
> > > >> > does
> > > >> > > > is:
> > > >> > > >
> > > >> > > > public static void main(String[] args) throws IOException {
> > > >> > > >     Configuration config = HBaseConfiguration.create();
> > > >> > > >     HTable table = new HTable(config, "s1");
> > > >> > > >     System.out.println(table.getTableName());
> > > >> > > > }
> > > >> > > >
> > > >> > > > hbase-site.xml:
> > > >> > > >
> > > >> > > > <property>
> > > >> > > >     <name>hbase.rootdir</name>
> > > >> > > >     <value>hdfs://172.16.144.150:8020/hbase</value>
> > > >> > > >   </property>
> > > >> > > >   <property>
> > > >> > > >     <name>zookeeper.znode.parent</name>
> > > >> > > >     <value>/hbase</value>
> > > >> > > >   </property>
> > > >> > > >   .......
> > > >> > > >   <property>
> > > >> > > >     <name>zookeeper.znode.rootserver</name>
> > > >> > > >     <value>root-region-server</value>
> > > >> > > >   </property>
> > > >> > > >   <property>
> > > >> > > >     <name>hbase.zookeeper.quorum</name>
> > > >> > > >     <value>172.16.144.150</value>
> > > >> > > >   </property>
> > > >> > > >
> > > >> > > > When I run my java client, I get the error unknown host:
> > > >> > > > localhost.localdomain:
> > > >> > > >
> > > >> > > > Initiating client connection, connectString> 172.16.144.150:2181