Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase >> mail # user >> HRegionserver daemon is not running on region server node


+
Vamshi Krishna 2011-11-17, 06:40
Copy link to this message
-
Re: HRegionserver daemon is not running on region server node
I suspect that the daemon's are binding to 127.0.0.1 instead of
10.0.1.54 on the master. You can check this by running netstat -anp. I
would recommend either configuring the /etc/hosts to bind the
vamshikrishna-desktop and vamshi-laptop hostnames to the 10.0.1.x
addresses.

-Joey

On Thu, Nov 17, 2011 at 1:40 AM, Vamshi Krishna <[EMAIL PROTECTED]> wrote:
> hi
> i am working with 2 node hbase cluster as shown below
> On  node1 (10.0.1.54) : master node, region server, hadoop namenode, hadoop
> datanode
> on node2 (10.0.1.55): region server, hadoop datanode.
> When i start both hadoop then hbase, all daemons are running properly on
> masternode i.e node1,
> 2404 NameNode
> 3657
> 3007 TaskTracker
> 2848 JobTracker
> 3522 HRegionServer
> 3848 Main
> 3292 HQuorumPeer
> 2769 SecondaryNameNode
> 3345 HMaster
> 2575 DataNode
> 4768 Jps
>  but on node2, only TaskTracker and Datanode daemons are running, the
> HRegionServer daemon is not running.
> I provide some files which may be helpful in helping me. i have my
> /etc/hosts file of node1 (vamshikrishna-desktop) has
> # /etc/hosts (for master AND slave)
>
> 127.0.0.1       localhost
> 127.0.1.1       vamshikrishna-desktop
> 10.0.1.54 hbase-master  hadoop-namenode
> 10.0.1.55 hbase-regionserver1   hadoop-datanode1
>
> and file {HBASE_HOME}/conf/regionservers has
>
> hbase-regionserver1
> hbase-master
>
> i have my /etc/hosts file of node2 (vamshikrishna-laptop) has
> 127.0.0.1    localhost
> 127.0.0.1    vamshi-laptop
> 10.0.1.54 hbase-master  hadoop-namenode
> 10.0.1.55 hbase-regionserver1 hadoop-datanode1
>
> and file {HBASE_HOME}/conf/regionservers has
>  localhost
>
> Please can anybody help me in finding out what is the reason for
> Regionserver not running on node2..?  And moreover when i run
> start-hbase.sh , it will display error like
> hbase-regionserver1: bash: line 0: cd: {HBASE_HOME}/bin/..: No such file or
> directory
> hbase-regionserver1: bash: {HBASE_HOME}/bin/hbase-daemon.sh: No such file
> or directory  , but i could find out {HBASE_HOME}/bin/hbase-daemon.sh
> clearly.. i don't know what went wrong..!
>  please can any body help?
>
> --
> *Regards*
> *
> Vamshi Krishna
> *
>

--
Joseph Echeverria
Cloudera, Inc.
443.305.9434
+
Vamshi Krishna 2011-11-25, 06:51
+
Suraj Varma 2011-11-26, 20:35
+
Vamshi Krishna 2011-11-27, 07:20
+
Suraj Varma 2011-11-27, 20:34
+
Vamshi Krishna 2011-11-28, 06:58
+
Suraj Varma 2011-11-28, 15:30
+
Vamshi Krishna 2011-11-29, 06:31
+
Vamshi Krishna 2011-11-17, 14:34
+
Jean-Daniel Cryans 2011-11-17, 22:33
+
Vamshi Krishna 2011-11-19, 06:42
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB