Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HBase >> mail # user >> mapper not running on the same region server


+
Rohit Kelkar 2011-12-06, 08:50
+
Stack 2011-12-06, 15:08
+
Rohit Kelkar 2011-12-07, 05:21
Copy link to this message
-
Re: mapper not running on the same region server
Hi,

Do you have maybe an issue with naming. HBase takes the hostname (as shown in the UI and the ZK dump there) and hints that to the MR framework. But if that resolves to different names, then no match can be made and the node to run the task on is chosen by random. Could you verify?

Lars

On Dec 7, 2011, at 6:21 AM, Rohit Kelkar wrote:

> My hadoop cluster has 3 nodes in it and hbase too runs on the same 3
> nodes. But the table that I am speaking of has only one region and
> http://master:50030/jobtracker.jsp shows only one mapper running.
> - Rohit Kelkar
>
> On Tue, Dec 6, 2011 at 8:38 PM, Stack <[EMAIL PROTECTED]> wrote:
>> On Tue, Dec 6, 2011 at 12:50 AM, Rohit Kelkar <[EMAIL PROTECTED]> wrote:
>>> I am running a mapreduce job on a hbase table. I hava a 3 node
>>> cluster. Currently the table has only a few rows. When I visit the
>>> http://master:60010/master.jsp I can see that the table resides on
>>> only one region server. When I run my mapreduce job on this table I
>>> see the mapper running on a different node of my cluster. Shouldn't
>>> the mapper be running on the same node that hosts the table?
>>> I am using the TableMapReduceUtil.initTableMapperJob method to
>>> initialize the mapreduce job.
>>>
>>
>> Yes.  Mappers should be running by the data.
>>
>> You have only one region in your table or more than one region and
>> more than one mapper is running?
>>
>> St.Ack
+
Rohit Kelkar 2011-12-09, 09:29
+
Lars George 2011-12-09, 11:00