Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # dev >> compile hbase in linux and windows problem


Copy link to this message
-
Re: compile hbase in linux and windows problem
Thanks a lot,
After using cygwin, the first problem solved and build successful.
My linux is behand a proxy and have some problem to access internet, linux and windows env is below:

   windows
       1.hbase version:0.90.1

2.Maven version:3.0.3

       3.Java version:1.6.0_23

4.OS:windows7(online)

   Linux:
       1.hbase version:0.90.1

2.Maven version:3.0.3

       3.Java version:1.6.0_22

4.OS:"linux", version: "2.6.32.12-0.7-default", arch: "amd64", family: "unix"

The second problem below, do you have some idea?

>
>      2. I copy the windows's repository folder to  Linux,because My Linux  entironment can not access entironment.
>
>      [mvn compile] by Maven ,compile is successful. but the target folder is not same with the hbase-0.90.1.tar.gz.
>
>      there is no jar file. what's wrong?
>
>       -target
>
>              + classes
>              + generated-sources
>              + hbase-webapps
>              + maven-shared-archive-resources
>              - .plxarc

Zhou Shuaifeng(Frank)
-------------------------------------------------------------------------------------------------------------------------------------
This e-mail and its attachments contain confidential information from HUAWEI, which
is intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

-----邮件原件-----
发件人: Suraj Varma [mailto:[EMAIL PROTECTED]]
发送时间: 2011年3月22日 1:34
收件人: [EMAIL PROTECTED]
主题: Re: compile hbase in linux and windows problem

I think you may be running into an error while executing the
saveVersion.sh under hbase-0.90.1/src directory - this fails if cygwin
is not available on the windows PATH (e.g. if you do ls in windows
command window, does it list files correctly?)

Also - specifically, what command did you run to build hbase on
windows (full command line including maven targets)?

Can you also describe your build machine environment a bit more - are
you behind a proxy or an authenticated proxy for instance? Do you have
cygwin on the machine and is it on your PATH?

One recommendation is to turn off running tests during the build (it
saves quite a bit of time, and you can always run it again, if needed)
... so, use -DskipTests command line argument to turn off the tests
during your build.

If you are still facing the issue after doing all the basic checks
like JAVA_HOME, Maven version, cygwin setup etc, turn on the -e Maven
switches to get fuller stack traces to see what exactly is failing.

I've been building on Windows for a while - and it definitely works.
--Suraj