Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> HBase shell does not start


Copy link to this message
-
Re: HBase shell does not start
At least now we know it's because of that ;)

But I agree this should not impact the shell start. When RVM is there,
do you have a classpath already setup with the ruby jars in it? Do you
have $JRUBY_HOME setup?

2013/4/5 Christoph Pilka <[EMAIL PROTECTED]>:
> OK, that's strange. I've removed RVM and base shell is started properly. Hmhm :(
>
> On Apr 6, 2013, at 2:52 AM, Jean-Marc Spaggiari <[EMAIL PROTECTED]> wrote:
>
>> I just tried and it's working fine:
>> jmspaggi@hbasetest:~/hbase$ wget
>> http://apache.mirror.rafal.ca/hbase/hbase-0.94.6.1/hbase-0.94.6.1.tar.gz
>> --2013-04-05 20:39:29--
>> http://apache.mirror.rafal.ca/hbase/hbase-0.94.6.1/hbase-0.94.6.1.tar.gz
>> Résolution de apache.mirror.rafal.ca (apache.mirror.rafal.ca)...
>> 207.210.46.249, 2001:470:1d:3c0:216:3eff:fe3f:746a
>> Connexion vers apache.mirror.rafal.ca
>> (apache.mirror.rafal.ca)|207.210.46.249|:80...connecté.
>> requête HTTP transmise, en attente de la réponse...200 OK
>> Longueur: 57332359 (55M) [application/x-gzip]
>> Sauvegarde en : «hbase-0.94.6.1.tar.gz»
>>
>> 100%[======>] 57332359     593K/s   ds 89s
>>
>> 2013-04-05 20:40:58 (627 KB/s) - «hbase-0.94.6.1.tar.gz» sauvegardé
>> [57332359/57332359]
>>
>> jmspaggi@hbasetest:~/hbase$ tar -xzf hbase-0.94.6.1.tar.gz
>> jmspaggi@hbasetest:~/hbase$ cd hbase-0.94.6.1/
>> jmspaggi@hbasetest:~/hbase/hbase-0.94.6.1$ bin/start-hbase.sh
>> starting master, logging to
>> /home/jmspaggi/hbase/hbase-0.94.6.1/bin/../logs/hbase-jmspaggi-master-hbasetest.out
>> jmspaggi@hbasetest:~/hbase/hbase-0.94.6.1$ bin/hbase shell
>> HBase Shell; enter 'help<RETURN>' for list of supported commands.
>> Type "exit<RETURN>" to leave the HBase Shell
>> Version 0.94.6.1, r1464658, Thu Apr  4 10:58:50 PDT 2013
>>
>> hbase(main):001:0> list
>> TABLE
>> 0 row(s) in 0.5360 seconds
>>
>> hbase(main):002:0>
>>
>> Even when HBase is down it should be working:
>>
>> jmspaggi@hbasetest:~/hbase/hbase-0.94.6.1$ bin/stop-hbase.sh
>> stopping hbase...........
>> jmspaggi@hbasetest:~/hbase/hbase-0.94.6.1$ bin/hbase shell
>> HBase Shell; enter 'help<RETURN>' for list of supported commands.
>> Type "exit<RETURN>" to leave the HBase Shell
>> Version 0.94.6.1, r1464658, Thu Apr  4 10:58:50 PDT 2013
>>
>> So I don't think your issue is HBase related.
>>
>> Do you have Ruby jars installed somewhere else in your system?
>>
>> JM
>>
>> 2013/4/5 Christoph Pilka <[EMAIL PROTECTED]>:
>>> Hi,
>>>
>>> I get the error when I try to start the shell by a simple "bin/hbase shell"
>>>
>>> On Apr 6, 2013, at 2:37 AM, Jean-Marc Spaggiari <[EMAIL PROTECTED]> wrote:
>>>
>>>> Hi Chris,
>>>>
>>>> How are you getting that?
>>>>
>>>> So you installed HBase, have started it, and then tried to launch
>>>> hbase shell? You are getting this error when the shell is starting? Or
>>>> while executing a specific command?
>>>>
>>>> JM
>>>>
>>>> 2013/4/5 Christoph Pilka <[EMAIL PROTECTED]>:
>>>>> Hi all,
>>>>>
>>>>> Anyone has an idea what's going wrong here? I've downloaded the HBase 0.94.6.1 tarball, installed HBase on my Mac OS X 10.8 box but get always the same error launching the hbase shell:
>>>>>
>>>>> NoMethodError: undefined method `getTerminal' for Java::Jline::Terminal:Module
>>>>> refresh_width at /usr/local/hbase-0.94.6.1/bin/../bin/../lib/ruby/shell/formatter.rb:34
>>>>> initialize at /usr/local/hbase-0.94.6.1/bin/../bin/../lib/ruby/shell/formatter.rb:47
>>>>> It's the same with the Homebrew prepackaged version of HBase ...
>>>>>
>>>>> I'm running
>>>>>
>>>>> java version "1.7.0_17"
>>>>> Java(TM) SE Runtime Environment (build 1.7.0_17-b02)
>>>>> Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)
>>>>> Many thanks in advance!
>>>>>
>>>>> Cheerio, Chris
>>>
>