Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
MapReduce >> mail # user >> Re: Requesting containers on a specific host


Copy link to this message
-
Re: Requesting containers on a specific host
Thanks Arun, it seems to be available with 2.1.0-beta, when will that be
released? Or if I want it now, could I get from the trunk?

-Kishore
On Thu, Jul 4, 2013 at 5:58 PM, Arun C Murthy <[EMAIL PROTECTED]> wrote:

> To guarantee nodes on a specific container you need to use the whitelist
> feature we added recently:
>
> https://issues.apache.org/jira/browse/YARN-398
>
> Arun
>
> On Jul 4, 2013, at 3:14 AM, Krishna Kishore Bonagiri <
> [EMAIL PROTECTED]> wrote:
>
> I could get containers on specific nodes using addContainerRequest() on
> AMRMClient. But there are issues with it. I have two nodes, node1 and node2
> in my cluster. And, my Application Master is trying to get 3 containers on
> node1, and 3 containers on node2 in that order.
>
> While trying to request on node1, it sometimes gives me those on node2,
> and vice verse. When I get a container on a different node than the one I
> need, I release it and make a fresh request. I am having to do like that
> forever to get a container on the node I need.
>
>  Though the node I am requesting has enough resources, why does it keep
> giving me containers on the other node? How can I make sure I get a
> container on the node I want?
>
> Note: I am using the default scheduler, i.e. Capacity Scheduler.
>
> Thanks,
> Kishore
>
>
> On Fri, Jun 21, 2013 at 7:25 PM, Arun C Murthy <[EMAIL PROTECTED]>wrote:
>
>> Check if the hostname you are setting is the same in the RM logs…
>>
>> On Jun 21, 2013, at 2:15 AM, Krishna Kishore Bonagiri <
>> [EMAIL PROTECTED]> wrote:
>>
>> Hi,
>>   I am trying to get container on a specific host, using setHostName(0
>> call on ResourceRequest, but could not get allocated anything forever,
>> which just works fine when I change the node name to "*". I am working on a
>> single node cluster, and I am giving the name of the single node I have in
>> my cluster.
>>
>>   Is there any specific format that I need to give for setHostName(), why
>> is it not working...
>>
>> Thanks,
>> Kishore
>>
>>
>>  --
>> Arun C. Murthy
>> Hortonworks Inc.
>> http://hortonworks.com/
>>
>>
>>
>
> --
> Arun C. Murthy
> Hortonworks Inc.
> http://hortonworks.com/
>
>
>