Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Hive >> mail # dev >> [VOTE] Apache Hive 0.9.0 Release Candidate 0


Copy link to this message
-
Re: [VOTE] Apache Hive 0.9.0 Release Candidate 0
Regarding HIVE-2795, that Python script was intended to solve two problems.

1) The null pointer exception that resulted from calling describe
formatted on a view partition

2) View partitions did not have storage descriptors, so they did not have
a concept of region like other objects.

2 no longer seems to be an issue.  1 could also be solved by not
displaying storage information for view partitions when describe formatted
is called on them, which seems reasonable since they are purely metadata.

I can add a patch removing the need for this script and the script itself
to be included in the release.

Kevin Wilfong

On 4/16/12 10:53 AM, "Carl Steinbach" <[EMAIL PROTECTED]> wrote:

>-1
>
>* RELEASE_NOTES.txt needs to be updated.
>
>* The Postgres metastore upgrade scripts should be excluded from the
>tarball since they are not current. There is already a build property that
>handles this ("include.postgres"), which should default to false.
>
>* HIVE-2795 added a python metastore upgrade script located in
>scripts/metastore/upgrade. This script is not mentioned in any of the
>README.txt files, and it's also not clear which version of Python is
>required to run it. Furthermore, the docs in the python script are not
>very
>clear, probably won't work with Derby, and reference a dependency in
>"trunk/build/dist/lib/py" which is not present in the tarball.
>
>* The lib/ directory contains some new JARs which are not covered in the
>LICENSE file (it's also possible that these are not really required), as
>well as a couple cases of multiple versions of the same JAR. Here are the
>ones that jump out at me, though there are probably some I missed:
>** JavaEWAH-0.3.2
>** antlr-2.7.7 and antlr-3.0.1?
>** commons-codec-1.3 and commons-codec-1.4?
>** commons-logging-1.0.4 and commons-logging-1.1.1?
>** hamcrest-core-1.1
>** hsqldb-1.8.0.10
>** kfs-0.3
>** oro-2.0.8 (This uses v1.1 of the ASF license)
>
>Thanks.
>
>Carl
>
>On Fri, Apr 13, 2012 at 3:28 PM, Ashutosh Chauhan
><[EMAIL PROTECTED]>wrote:
>
>> Couple more points:
>>
>> Maven artifacts are available at
>> https://repository.apache.org/content/repositories/orgapachehive-043/
>>for
>> folks to try out.
>>
>> Vote runs for 3 business days so will expire on Wednesday, 4/18.
>>
>> Thanks,
>> Ashutosh
>>
>> On Fri, Apr 13, 2012 at 11:50, Ashutosh Chauhan <[EMAIL PROTECTED]
>> >wrote:
>>
>> > Hey all,
>> >
>> > Apache Hive 0.9.0-rc0 is out and available at
>> > http://people.apache.org/~hashutosh/hive-0.9.0-rc0/
>> >
>> > Release notes are available at:
>> >
>>
>>https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12310843
>>&version=12317742
>> >
>> > Please give it a try, let us know.
>> >
>> > Hive PMC members: Please test and vote.
>> >
>> > Thanks,
>> > Ashutosh
>> >
>>
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB