Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Plain View
HDFS, mail # user - Errors come out when starting Balancer


+
YouPeng Yang 2013-02-24, 15:18
+
YouPeng Yang 2013-02-25, 05:05
Copy link to this message
-
Re: Errors come out when starting Balancer
Harsh J 2013-02-25, 07:18
Hi,

A few points:

- The property "fs.default.name" has been deprecated in favor of the
newer name "fs.defaultFS".
- When using nameservice IDs, you shouldn't rely on the RPC address.
That is, your fs.defaultFS should instead simply be "hdfs://ns1", and
the config will load the right RPC that is bound to that NS
automatically from the hdfs-site.xml.

On Mon, Feb 25, 2013 at 10:35 AM, YouPeng Yang
<[EMAIL PROTECTED]> wrote:
> Hi .
>   Sorry to bother you againt.
>
>   I need to close this question  by myself.
>   Here is my core-site.xml:
>   ******************************************************************
>   <configuration>
>    <property>
>    <name>fs.default.name</name>
>    <value>hdfs://Hadoop01:8020</value>
>   </property>
>  </configuration>
>   ******************************************************************
>  my hdfs-site.xml:
>  *********************************************************************
> <configuration>
>     <property>
>        <name>dfs.nameservices</name>
>        <value>ns1,ns2</value>
>    </property>
>    <property>
>        <name>dfs.namenode.rpc-address.ns1</name>
>       <value>Hadoop01:8040</value>
>    </property>
> .... Other common configuration ...
> </configuration>
> **********************************************************************
>
> When start the  balancer,the script using the   fs.default.name of
> core-site.xml by defulat.
> according to hdfs-site.xml,the port 8020 does no start.So it goes fo fail
> when i start the balancer usig the port 8020 of core-site.xml.
>
> So the  ports of  fs.default.name and
> dfs.namenode.rpc-address.<nameserviceid> shoud be consistent.
>
>
> Thanks
>
> Regards
>
>
>
>
>
> 2013/2/24 YouPeng Yang <[EMAIL PROTECTED]>
>>
>> Hi ALL
>>
>>   I start the  Balancer on the HDFS Federation,however it comes an error:
>> java.net.ConnectException: Call From Hadoop01/10.167.14.221 to
>> Hadoop01:8020 failed on connection exception: java.net.ConnectException:
>> Connection refused; For more details see:
>> http://wiki.apache.org/hadoop/ConnectionRefused.  Exiting ...
>> Balancing took 11.163 seconds
>>
>>  How Can i solve this.
>>
>> By the way,I have done what explained on the
>> http://wiki.apache.org/hadoop/ConnectionRefused  when i build my basic and
>> original HDFS cluster.So i think the above error maybe because of another
>> reasons.
>>
>> thanks
>>
>> Regards.
>>
>

--
Harsh J