Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> Coprocessor Errors


Copy link to this message
-
RE: Coprocessor Errors
No backward API compatibility, for example.

Best regards,
Vladimir Rodionov
Principal Platform Engineer
Carrier IQ, www.carrieriq.com
e-mail: [EMAIL PROTECTED]

________________________________________
From: Young Kim [[EMAIL PROTECTED]]
Sent: Monday, September 30, 2013 6:04 PM
To: [EMAIL PROTECTED]
Subject: Re: Coprocessor Errors

Is there a reason why it has to be guava-11.0.2? We're trying to use guava-14.0.1.

On Monday, September 30, 2013 at 5:59 PM, Vladimir Rodionov wrote:

> Yes, you have to restart servers.
> FYI, the right version of guava - guava-11.0.2.jar
>
> Best regards,
> Vladimir Rodionov
> Principal Platform Engineer
> Carrier IQ, www.carrieriq.com (http://www.carrieriq.com)
> e-mail: [EMAIL PROTECTED] (mailto:[EMAIL PROTECTED])
>
> ________________________________________
> From: Young Kim [[EMAIL PROTECTED] (mailto:[EMAIL PROTECTED])]
> Sent: Monday, September 30, 2013 4:57 PM
> To: [EMAIL PROTECTED] (mailto:[EMAIL PROTECTED])
> Subject: Re: Coprocessor Errors
>
> Thanks for the feedback. That is indeed what it looks like. I just looked under /usr/lib/hbase/lib, and there were two instances of guava jars in our region and master servers. After removing the deprecated one, it seems like this error is still popping up. Does anyone know if a restart is required for the changes to take affect?
>
>
> On Monday, September 30, 2013 at 4:28 PM, Vladimir Rodionov wrote:
>
> > Guava lib issue (more than one in a CLASSPATH)?
> >
> > http://code.google.com/p/guava-libraries/issues/detail?id=1318
> >
> > Best regards,
> > Vladimir Rodionov
> > Principal Platform Engineer
> > Carrier IQ, www.carrieriq.com (http://www.carrieriq.com)
> > e-mail: [EMAIL PROTECTED] (mailto:[EMAIL PROTECTED])
> >
> > ________________________________________
> > From: Ted Yu [[EMAIL PROTECTED] (mailto:[EMAIL PROTECTED])]
> > Sent: Monday, September 30, 2013 3:10 PM
> > To: [EMAIL PROTECTED] (mailto:[EMAIL PROTECTED])
> > Subject: Re: Coprocessor Errors
> >
> > bq. unable to read call parameters: class
> > com.google.common.collect.AbstractMapBasedMultimap
> > overrides final method setMap.(Ljava/util/Map;)V
> >
> > Can you show us the classpath ?
> >
> > Thanks
> >
> >
> > On Mon, Sep 30, 2013 at 3:01 PM, Young Kim <[EMAIL PROTECTED] (mailto:[EMAIL PROTECTED])> wrote:
> >
> > > Hello,
> > >
> > > I've been running into this odd error when running a coprocessor on
> > > hbase-0.94.6:
> > >
> > > 13/09/30 14:53:35 INFO zookeeper.ZooKeeper: Client
> > > environment:zookeeper.version=3.4.5-1392090, built on 09/30/2012 17:52 GMT
> > > 13/09/30 14:53:35 INFO zookeeper.ZooKeeper: Client environment:host.name (http://host.name)
> > > =templar1
> > > 13/09/30 14:53:35 INFO zookeeper.ZooKeeper: Client
> > > environment:java.version=1.7.0_21
> > > 13/09/30 14:53:35 INFO zookeeper.ZooKeeper: Client
> > > environment:java.vendor=Oracle Corporation
> > > 13/09/30 14:53:35 INFO zookeeper.ZooKeeper: Client
> > > environment:java.home=/usr/java/jdk1.7.0_21/jre
> > > 13/09/30 14:53:35 INFO zookeeper.ZooKeeper: Client
> > > environment:java.class.path=/opt/content/hbase-coproc-cr-current.jar
> > > 13/09/30 14:53:35 INFO zookeeper.ZooKeeper: Client
> > > environment:java.library.path=/usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib
> > > 13/09/30 14:53:35 INFO zookeeper.ZooKeeper: Client
> > > environment:java.io.tmpdir=/tmp
> > > 13/09/30 14:53:35 INFO zookeeper.ZooKeeper: Client
> > > environment:java.compiler=<NA>
> > > 13/09/30 14:53:35 INFO zookeeper.ZooKeeper: Client environment:os.name (http://os.name)
> > > =Linux
> > > 13/09/30 14:53:35 INFO zookeeper.ZooKeeper: Client
> > > environment:os.arch=amd64
> > > 13/09/30 14:53:35 INFO zookeeper.ZooKeeper: Client
> > > environment:os.version=2.6.32-279.19.1.el6.x86_64
> > > 13/09/30 14:53:35 INFO zookeeper.ZooKeeper: Client environment:user.name (http://user.name)
> > > =croll
> > > 13/09/30 14:53:35 INFO zookeeper.ZooKeeper: Client
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB