Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # dev >> DISCUSS: Have hbase require at least hadoop 1.0.0 in hbase 0.96.0?


Copy link to this message
-
Re: DISCUSS: Have hbase require at least hadoop 1.0.0 in hbase 0.96.0?
I'm wondering why HDFS security support should be mandatory?  Append makes
sense because there's no way to have a durable system without it.
Security is currently an optional feature & implemented as an HBase
co-processor (vs core), correct?  Is there a problem (other than minor
inconvenience) with using introspection APIs for security in the core and
then warning if security is enabled but the API is unreachable?

Nicolas

On 3/2/12 3:50 PM, "Ted Yu" <[EMAIL PROTECTED]> wrote:

>Hadoop 0.22 currently doesn't support security.
>
>FYI
>
>On Fri, Mar 2, 2012 at 11:24 AM, Stack <[EMAIL PROTECTED]> wrote:
>
>> Should we make it so hbase 0.96.0 requires at least hadoop 1.0.0?
>> This would mean we would no longer support running on older versions
>> such as branch-0.20-append (and perhaps stuff like CDH2?)?
>>
>> Requiring Hadoop 1.0.0 at least means we can presume security and
>> append.  We also narrow the set of hadoops we need to support
>> simplifying things for ourselves some.
>>
>> What you lot think?
>> St.Ack
>>