Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
Flume >> mail # dev >> Maven build of newer version Flume


Copy link to this message
-
Maven build of newer version Flume
Devs,
  I am bit stumped with this. If i were to change '1.3.1'  in all the poms
to say '1.3.2-SNAPSHOT'  and then run a .. mvn clean install -DskipTests

the aggregate-jar goal fails because the build step is not using the
version just being built and instead trying to look for it in a
local/remote repo.

any clue why ? I am assuming something like this is done each time the
project moves to a newer version/branch. or is it different ?

-roshan

Here is sampling of the output of the mvn clean install command...
Downloading:
http://repo1.maven.org/maven2/org/apache/flume/flume-ng-sdk/1.3.2-SNAPSHOT/maven-metadata.xml
Downloading:
http://repository.apache.org/snapshots/org/apache/flume/flume-ng-sdk/1.3.2-SNAPSHOT/maven-metadata.xml
Downloading:
http://repo1.maven.org/maven2/org/apache/flume/flume-ng-sdk/1.3.2-SNAPSHOT/flume-ng-sdk-1.3.2-SNAPSHOT.jar
Downloading:
http://repository.apache.org/snapshots/org/apache/flume/flume-ng-sdk/1.3.2-SNAPSHOT/flume-ng-sdk-1.3.2-SNAPSHOT.jar
[WARNING] The following dependencies could not be resolved at this point of
the build but seem to be part of the reactor:
[WARNING] o org.apache.flume:flume-ng-sdk:jar:1.3.2-SNAPSHOT (compile)
[WARNING] Try running the build up to the lifecycle phase "package"
Downloading:
http://repo1.maven.org/maven2/org/apache/flume/flume-ng-configuration/1.3.2-SNAPSHOT/maven-metadata.xml
Downloading:
http://repository.apache.org/snapshots/org/apache/flume/flume-ng-configuration/1.3.2-SNAPSHOT/maven-metadata.xml
Downloading:
http://repo1.maven.org/maven2/org/apache/flume/flume-ng-configuration/1.3.2-SNAPSHOT/flume-ng-configuration-1.3.2-SNAPSHOT.jar
Downloading:
http://repository.apache.org/snapshots/org/apache/flume/flume-ng-configuration/1.3.2-SNAPSHOT/flume-ng-configuration-1.3.2-SNAPSHOT.jar
[WARNING] The following dependencies could not be resolved at this point of
the build but seem to be part of the reactor:
[WARNING] o org.apache.flume:flume-ng-sdk:jar:1.3.2-SNAPSHOT (compile)
[WARNING] o org.apache.flume:flume-ng-configuration:jar:1.3.2-SNAPSHOT
(compile)
[WARNING] Try running the build up to the lifecycle phase "package"
Then some more...

Downloading:
http://repo1.maven.org/maven2/org/apache/flume/flume-ng-sdk/1.3.2-SNAPSHOT/maven-metadata.xml
Downloading:
http://repository.apache.org/snapshots/org/apache/flume/flume-ng-sdk/1.3.2-SNAPSHOT/maven-metadata.xml
Downloading:
http://repo1.maven.org/maven2/org/apache/flume/flume-ng-sdk/1.3.2-SNAPSHOT/flume-ng-sdk-1.3.2-SNAPSHOT.jar
Downloading:
http://repository.apache.org/snapshots/org/apache/flume/flume-ng-sdk/1.3.2-SNAPSHOT/flume-ng-sdk-1.3.2-SNAPSHOT.jar
[WARNING] The following dependencies could not be resolved at this point of
the build but seem to be part of the reactor:
[WARNING] o org.apache.flume:flume-ng-sdk:jar:1.3.2-SNAPSHOT (compile)
[WARNING] Try running the build up to the lifecycle phase "package"
Downloading:
http://repo1.maven.org/maven2/org/apache/flume/flume-ng-configuration/1.3.2-SNAPSHOT/maven-metadata.xml
Downloading:
http://repository.apache.org/snapshots/org/apache/flume/flume-ng-configuration/1.3.2-SNAPSHOT/maven-metadata.xml
Downloading:
http://repo1.maven.org/maven2/org/apache/flume/flume-ng-configuration/1.3.2-SNAPSHOT/flume-ng-configuration-1.3.2-SNAPSHOT.jar
Downloading:
http://repository.apache.org/snapshots/org/apache/flume/flume-ng-configuration/1.3.2-SNAPSHOT/flume-ng-configuration-1.3.2-SNAPSHOT.jar
continues.. now the aggregate-jar starts having some trouble...
[INFO] --- maven-javadoc-plugin:2.8.1:aggregate-jar (javadoc-jar) @
flume-parent ---
[WARNING] The dependency:
[org.apache.flume:flume-ng-sdk:jar:1.3.2-SNAPSHOT] can't be resolved but
has been found in the reactor (probably snapshots).
This dependency has been excluded from the Javadoc classpath. You should
rerun javadoc after executing mvn install.
[WARNING] IGNORED to add some artifacts in the classpath. See above.
[WARNING] The dependency:
[org.apache.flume:flume-ng-sdk:jar:1.3.2-SNAPSHOT] can't be resolved but
has been found in the reactor (probably snapshots).
This dependency has been excluded from the Javadoc classpath. You should
rerun javadoc after executing mvn install.
[WARNING] The dependency:
[org.apache.flume:flume-ng-configuration:jar:1.3.2-SNAPSHOT] can't be
resolved but has been found in the reactor (probably snapshots).
This dependency has been excluded from the Javadoc classpath. You should
rerun javadoc after executing mvn install.
[WARNING] IGNORED to add some artifacts in the classpath. See above.
[WARNING] The dependency:
[org.apache.flume:flume-ng-sdk:jar:1.3.2-SNAPSHOT] can't be resolved but
has been found in the reactor (probably snapshots).
This dependency has been excluded from the Javadoc classpath. You should
rerun javadoc after executing mvn install

Finally ends with build errors:
[INFO] BUILD FAILURE
[INFO]
[INFO] Total time: 14.668s
[INFO] Finished at: Thu Apr 11 21:56:50 PDT 2013
[INFO] Final Memory: 24M/81M
[INFO]
[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-javadoc-plugin:2.8.1:aggregate-jar
(javadoc-jar) on project flume-parent: MavenReportException: Error while
creating archive:
[ERROR] Exit code: 1 -
/Users/rnaik/Projects/flume-hw/flume-ng-core/src/main/java/org/apache/flume/event/EventHelper.java:24:
package org.apache.commons.io does not exist
[ERROR] import org.apache.commons.io.HexDump;
[ERROR] ^
[ERROR]
/Users/rnaik/Projects/flume-hw/flume-ng-configuration/src/main/java/org/apache/flume/Context.java:26:
package com.google.common.base does not exist
[ERROR] import com.google.common.base.Preconditions;
[ERROR] ^
[ERROR]
/Users/rnaik/Projects/flume-hw/flume-ng-configuration/src/main/java/org/apache/flume/Context.java:27:
package com.google.common.collect does not exist
[ERROR] import com.google.common.collect.ImmutableMap;
[ERROR] ^
[ERROR]
/Users/rnaik/Projects/flume-hw/flume-ng-configuration/src/main/java/org/apache/flume/Context.java:28:
package com.google.common.collect does not exist
[ERROR] import com.google.c
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB