Home | About | Sematext search-lucene.com search-hadoop.com
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> HBase is not running.


Copy link to this message
-
Re: HBase is not running.
Here is my dump of the sole log file in the logs directory:
http://bin.cakephp.org/view/2116332048
On Thu, May 23, 2013 at 6:20 PM, Jean-Daniel Cryans <[EMAIL PROTECTED]>wrote:

> On Thu, May 23, 2013 at 2:50 PM, Jay Vyas <[EMAIL PROTECTED]> wrote:
> > 1) Should hbase-master be changed to localhost?
> >
> > Maybe Try changing /etc/hosts to match the actual non loopback ip of
> your machine... (i.e. just run Ifconfig | grep 1 and see what ip comes out
> :))
> >  and make sure your /etc/hosts matches the file in my blog post, (you
> need hbase-master to be defined in your /etc/hosts...).
>
> hbase.master was dropped around 2009 now that we have zookeeper. So
> you can set it to whatever you want, it won't change anything :)
>
> >
> > 2) zookeeper parent seems bad..
> >
> > Change hbase-rootdir to "hbase" (in hbase.rootdir) so that it's
> consistent with what you defined in zookeeper parent node.
>
> Those two are really unrelated, /hbase is the default so no need to
> override it, and I'm guessing that hbase.rootdir is somewhere writable
> so that's all good.
>
> Now, regarding the "Check the value configured in
> 'zookeeper.znode.parent", it's triggered when the client wants to read
> the /hbase znode in ZooKeeper but it's unable to. If it doesn't exist,
> it might be because your HBase is homed elsewhere. It could also be
> that HBase isn't running at all so the Master never got to create it.
>
> BTW you can start the shell with -d and it's gonna give more info and
> dump all the stack traces.
>
> Going by this thread I would guess that HBase isn't running so the
> shell won't help. Another way to check is pointing your browser to
> localhost:60010 and see if the master is responding. If not, time to
> open up the log and see what's up.
>
> J-D
>