Home | About | Sematext search-lucene.com search-hadoop.com
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB
 Search Hadoop and all its subprojects:

Switch to Threaded View
HBase >> mail # user >> Couple of HBase related issues...


Copy link to this message
-
Re: Couple of HBase related issues...
Sounds like #1 is not HBase issue, but HBql issue.

http://www.hbql.com/xref/org/apache/hadoop/hbase/hbql/impl/MappingManager.html

May be this method should be synchronized:

*public* *void* validatePersistentMetadata() *throws* HBqlException {
On Mon, Apr 12, 2010 at 2:20 PM, Something Something <
[EMAIL PROTECTED]> wrote:

> I run into the following two issues related to HBase all the time, and
> therefore am wondering if there are any permanent fixes for these:
>
> 1) When I start Hadoop & HBase for the first time, and run a single job it
> runs successfully; but when I fire 2 (or more) jobs only one of them runs
> successfully and the other one fails with exception saying... "table
> system_mappings" doesn't exist.  Seems like some type of race condition.
> How do I bring up HBase with 'system_mappings' table already built?  Or, how
> do I avoid running into this issue?
>
> 2) After 30 minutes or so on in-activity, HBase (or may be Zookeeper) stops
> working.  I have to restart it.  How do I ensure that it always stays up?
>
> Thanks for the help.
>
>
NEW: Monitor These Apps!
elasticsearch, apache solr, apache hbase, hadoop, redis, casssandra, amazon cloudwatch, mysql, memcached, apache kafka, apache zookeeper, apache storm, ubuntu, centOS, red hat, debian, puppet labs, java, senseiDB